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About BioEdit

I ntroduction

BioEdit version 5.0.6
Copyright ©1997-2001

Tom Hall

Current version built 2/12/2001

BioEdit isabiological sequence editor that runsin Windows 95/98/NT/2000 and is intended
to provide basic functions for protein and nucleic sequence editing, alignment, manipulation and
analysis. Version 1.0 aphawas the very first version and was unfinished and very buggy.
Version 1.0 alpha Il was still unfinished and had a bunch of bugs too, but several things were
added and several bugsfixed. Inversion 2.0, an interface was added to add and configure
accessory analysis applications to run viaa graphical interface created by BioEdit. Also,
information-based dynamic shading of alignment positions was added.

Hydrophobicity/hydrophilicity profiles, interactive 2-D matrix data plotting and a few more
segquence manipulations were added in version 3. Version 4 added a graphical interface for
drawing and annotating plasmid vectors. Inversion 4.7.1 handling of sequence information and
memory were altered and a binary file format was added to alow fast saving and opening of
large alignments. The sequence capability was expanded to 20,000. In version 5, annotation of
sequence automatically or manually using all of the standard GenBank feature definitions was
added. Also, at the request of Isis Pharmaceuticals, Inc., sequence sorting and grouping, group
mani pulation, comment lines, and differentiation between residue and non-residue characters was
added. BioEdit is not intended to be a powerful sequence analysis program, but isinstead
intended to be a user friendly interface for sequence manipulation and linking to other, more
scientific analysis programs, both local and WWW-based. It is now suitable for large alignments
(>2000 sequences). The document interface was originally modeled after the very nice programs
SegApp and SeqPup by Don Gilbert.  SegApp (Macintosh) and SeqgPup (cross-platform) are
offered free of charge from Indiana University at:

ftp://iubio.bio.indiana.edu/molbio/seqpup/

An exceptional alignment program that is freely available for Windows 9x and NT is called
GeneDoc. GeneDoc isvery professiona and has nice protein alignment annotation and analysis,
shading and structural definition features not offered in BioEdit, as well as an internal
phylogenetic tree view of alignments. GeneDoc can be found on the World Wide Web:

http://www.psc.edu/biomed/genedoc

GeneDoc also has more sophisticated shading and scoring options than BioEdit to aid in hand
alignment of sequences, as well as better handling of graphics, the options for both wrapped and
extended alignment views, dynamic consensus sequence, and much smoother and faster
alignment scrolling and redrawing.



BioEdit is a C++ program written in Borland's C++ Builder. | am a graduate student in
Microbiology at North Carolina State University, and not atrained programmer. Thiswas my
introduction to the C++ language and is necessarily a side project (thisis not part of my doctoral
work). This program could be much smaller and more efficient. Nevertheless, BioEdit provides
an easy means for sequence alignment, output, and some analyses.



BioEdit Features

The main goal of BioEdit isto provide a useful tool for biologists who do not want to have to
know much about a program to utilize it. BioEdit isintuitive, menu-driven, and highly graphical
and offers agraphical interface for usersto run external analysis programs. The main functions
are intended to be visible by ssimply playing with the menu options.

Version 5.0.6 offersthe following features:

* Aneasy, graphical interface for sequence manipulation and editing.

* Variable editing options, including ‘select and drag’ dliding and 'grab and drag' sliding of
residues, variable selection options, mouse-click insert and delete of gaps, full column
selecting, on-screen editing with cut, copy and paste, and auto-scrolling of edit window.

* Anchor alignment columns to protect fixed regionsin an alignment.

» Automaticaly and manually annotate sequences with features such as introns, exons,
promoters, CDS, and all standard GenBank feature types. Automatically annotate other
sequences in an alignment using one sequence as a template.

»  Group sequences into color-coded families and lock group members for synchronized hand-
alignment.

» User-defined character-relevance (any characters can be set to be considered as relevant bases
in nucleic acid or amino acid sequences for the purposes of similarity shading, sequence
identity matrices, and conservation plot views.

e User-defined motif searching using standard Prosite nomenclature and utilizing IUPAC
charactersto allow searching in nucleic acid or amino acid sequences, as well as exact text
searches including or ignoring gaps.

* Lines may be defined as DNA, RNA, nucleic acid, protein, undefined, or Comments.
Comments may be used to hold general notes or things such as secondary structure mask
definitions, but do not contribute to conservation calculations.

* Rudimentary phylogenetic tree viewer which supports node flipping and printing.

* Link phylogenetic trees to alignments and save trees with BioEdit format alignment files.

» Append one alignment to the end of another.

» Configure accessory application interfaces to run external analysis programs through a
graphical interface created by BioEdit. Automatically feed information to and retrieve files
from external apps. External apps run in a separate thread to allow simultaneous use of
BioEdit while running time-consuming processes. Output from an external program may be
automatically opened by another program.

» Display, print and edit ABI trace files from ABI autosequencer model 377, 373, and 3700, as
well as SCF files of version 2 and 3, such as the files output by Licor sequencers.

* RNA comparative analysistools, including covariation, potential pairings, and mutual
information analyses.

o 2-D matrix plotter for mutual information output with dynamic data viewing with the mouse
pointer. (Also allows image copy/paste and bitmap save).

* Interactive 1-D plots of mutual information matrix rows and columns

» Save sequence annotation information in BioEdit or GenBank format



Align protein-encoding nucleic acid sequences through amino acid tranglation.

Search for conserved regionsin an aignment (find good PCR targets or help define motifs)
Search for user-defined motifsin nucleic acid or protein sequences or search exact text with
wildcards and choice of including or ignoring gaps.

Dynamic memory allocation with support for up to 20,000 sequences per document.
Sequences up to 4.6 million bases (the E. coli genome) have been tested successfully. The
prokaryotic 16S RNA alignment from the Ribosomal Database (29 Mb, 6205 sequences) has
been tested with simple manipulations. When saved in BioEdit Project file format, the 16S
RNA alignment loads in less than 10 sec. on a Pentium 233 Mhz with 80 Mb RAM.

Read and write GenBank, Fasta, Phylip and NBRF/PIR files internally and import/export
several other formats with Don Gilbert’ s ReadSeq.

Read and write large alignment files quickly with the BioEdit Project file format.

ClustalW multiple sequence alignment (interface internal, external program by Des Higgins
et. al.) with auto-update of aligned protein full titles and GenBank field information, as well
as nucleotide coding sequence when aligned from a protein view of nucleotide sequences.
Block copying of residuesto clipboard allowing for pasting of full alignments or parts of
alignments into aword processor.

Basic sequence manipulations (copy/paste of sequences between documents, translation and
degenerate encoding, RNA->DNA->RNA, reverse/complement, upper/lowercase).
Multiple document interface (Maximum of 20 open alignment documents at atime, but no
set l[imit on other open windows).

Six-Frame tranglation of nucleic acid sequences into Fasta-format ORF lists. Tested by
translating the E. coli genome (4.6 Mbases) into 10,125 sorted raw codon stretches of 100 or
more amino acids and 39,880 unsorted raw codon stretches of 50 or more amino acids.
Semi-automated plasmid/vector drawing and annotation with vectored graphics, automatic
restriction site and positional marking, automated polylinker view, and user-controlled
drawing objects

Save plasmid files as editable vectored graphic files or as bitmaps, copy to other graphics
applications, and print plasmids at printer’s full resolution.

Amino acid and nucleotide composition summaries and plots

'Revert to Saved' and 'undo’ functions.

Edit both amino acid and nucleic acid sequences.

Easy point-and-click color table editing, with different tables for protein and nucleic acid
Sequences.

Alignment-responsive shading based on information content of alignment positions.
BioEdit currently reads and writes GenBank, Fasta, NBRF/PIR, Phylip 3.2 and Phylip 4
formats and reads ClustalW and GCG formats.

Import/Export filter for 10 additional formats (Using Don Gilbert’ s ReadSeq).
Import/Append one file on to the end of another (regardless of file format).

Basic rich-text editor.

Internal restriction mapping utility with any or all-frames tranglation, multiple enzyme and
output options, including enzyme suppliers, and circular DNA option.

Browse restriction enzymes by manufacturer

Auto-linking to your favorite Web Browser (e.g., Netscape or Internet Explorer).



*  World Wide Web Bookmarks.

* NCBI BLAST toals, including BLAST 3.0 Internet client and local BLAST with the ability
to compile local databases from Fastafiles

» Configurable formatted text print with dynamic print preview,

» Configurable formatted shaded graphical output with dynamic preview, identity and
similarity shading, and ability to cut and paste directly to graphics/presentation program for
generation of figures.

» Entropy (lack of information) plotting of alignments

» Hydrophobicity profiles of multiple proteins using severa hydrophobicity scales, with
variable window width and option to analyze degapped sequences or alignments.

General overview of program and program or ganization

BioEdit was written in Borland C++ Builder 3.0 (started in C++ Builder 1.0). This (was)
Borland’ s newest C++ product which combines Borland C++ 5 with the Visual Component
Library (VCL) of Delphi, allowing for visual development of the user interface. The benefit of
using a Rapid Application Development (RAD) environment such asthisisthat it alowsfor the
easy creation of avery rich graphical interface. The drawback isthat the code is not portable.
BioEdit runs only in Windows 95, 98, NT and 2000. | originally planned to port BioEdit to
Win16, but | no longer plan to do this, since Windows 3.x is obsolete.

Organization: BioEdit currently supports the simultaneous editing of up to 50 documents. A
main control form contains menus to open documents, create new documents, set global options
such as color tables, codon table, and analysis preferences, and a window manager. Originaly,
each document had its own complete set of menus for all manipulations confined to that
document, however, this has been abandoned for a more traditional multiple document interface.
BioEdit does not use excessive physical memory (unless big alignments are being edited), but it
does appear to be a bit of aresource hog. BioEdit has alimit of 20,000 sequences per document
with no defined limit on sequence size. On a 233 MHz PC with 80 Mb of RAM, manipulating
the entire prokaryotic 16S rRNA alignment from the Ribosomal Database (6205 seqgs, 3319
characters each) works fine. Once saved in BioEdit format, thisfile opensin only afew seconds
(takes a couple of minutes from GenBank format).

The program file (BioEdit.exe) is found in the main installation directory. There should aso be
the following subdirectories:

» apps (accessory applications, Web pages and WWW bookmarks)
Currently, the following files should be in the apps folder (as shown in the file manager sorted by
name):
accApp.ini (accApp.def when first installed)
Bblast.html
BioEdit.html
blast_adv.gif
blast_form_0.gif



blastall.exe (not in the version without BLAST)
blastcl3.exe (not in the version without BLAST)
blast.txt

bookmark.txt

cap.doc
cap.exe
clear_inp.gif
clustaw.exe
clustalw.txt
cutter.html
Dnadist.doc
Dnadist.exe
Dnamlk.doc
Dnamlk.exe
DosAgw.exe (needed for PHY LIP programs)
Expasy.gif
fastDNAmI.doc
fastdnaml.exe
Fitch.doc
Fitch.exe
formatdb.exe (not in the version without BLAST)
IdPlot.exe
isrecsmall.gif
Kitsch.doc
Kitsch.exe
mod_ad.gif
mod_submit.gif
nnpredict.html
Note.gif
PFSCAN_form.html
phi_blast.gif
PHIBIlast.html
Phylip.map
Protdist.doc
Protdist.exe
Protpars.doc
Protpars.exe
psi_blast.gif
PSIBIlast.html
Readseg.exe
ReadSeq.txt
scnpsitl.html
Siblogo.gif
smweb.gif
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» database (for local BLAST databases, unless the version was installed without BLAST tools).
BioEdit (full version) comes with the following files in the database folder:
Ecoli.phr
Ecoli.pin
Ecoli.psq
Ecoli_ORFs.txt (text file with E. coli open reading frames).

 help
BioEdit.cnt
BioEdit.GID (not installed -- will appear after the first time help is accessed)
Bioedit.hlp

» tables
Blosum62
codon.tab
color.tab
dayhoff
defcolor.tab
enzyme.tab
Gce.vd
gonnet
Identify
match
Pam120
Pam250
Pam40
Pam80
Seqcode.val

The installation folder will aso contain the following files:
_deisreg.isr (instalation related file)
_isreg32.dll (installation related file)
BioEdit.exe (BioEdit executable)
DelsL1.isu (installation related file)
RNaseP_prot.gb (sample protein alignment
RNaseP_prot_genes.gb (sample DNA aignment)
RNaseP_RNA.gb (sample RNA alignment)
PBSSK _plus.pmd (Sample plasmid drawing)
bacterio.gb (sample protein alignment with GenBank information)
bacterio.bio (sample BioEdit file with GenBank information, graphical annotations, marker
flags, and sequence groups)
Y opD.gb (another sample file with GenBank info)
TreeView.zip (Excellent Phylogenetic tree viewer by Roderic D.M. Page, full installation)
TreeView.txt (Information on installing TreeView and configuring BioEdit to link tree-
generating accessories directly to it).
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license.txt (BioEdit license agreement)
ReadMe.txt (General information)

It isimportant that none of the folder names nor file names are changed, as parts of BioEdit will
not run correctly if these names are changed.

There will be afile caled “BioEdit.ini” found in your main Windows directory which contains
the initialization defaults and preferences for BioEdit. Although this file can be edited manually,
there should be no need and manual editing of thisfile is not recommended.

For alist of currently supported features and known problems, see BioEdit Features and Known
Problems/ Limitations.

Known problems/ Limitations

BioEdit isintended to be a general-purpose interface for several simple sequence manipulations,
genera alignment of sequences with an option for automated multiple alignment, optimal
pairwise alignment, and an emphasis on making hand alignment easy. Severa accessory
functions have been added over time (plasmid drawing, restriction mapping, ABI and SCF
viewing, RNA comparative analysis and graphical annotation among other features). However,
sophisticated search functions, specialized analyses such as protein secondary or tertiary structure
predictions, thermodynamic predictions of RNA structure, statistical analyses of alignment
quality, and probabilistic or neural network modeling of sequence patterns, alignment and
structure prediction are outside the scope of this program.

Although command-line accessory applications may be configured by the user, there are
programmed links to ClustalW and local BLAST and BLAST client 3. These links are not
guaranteed to work correctly if the Clustal program or BLAST programs are replaced with an
upgrade. Although the local BLAST and Clustal programs provided in the BioEdit installations
will continue to work, BLAST client 3 may not work correctly after the next time the NCBI
decides to changeits client and | am no longer supporting this program directly. The source code
may be offered for download at alater date, but is somewhat disorganized, not well commented,
and really constrained to Borland C++ Builder (which isthe main reason | don't bother to post
the source code).

Also, automated web links which feed a selected sequence to the web page (e.g. for BLAST, PSI-
BLAST, PROSITE profile scan) work by keeping alocal HTML template for the web page, the
source for which BioEdit edits to include the selected sequence within the query text area.
Because of the highly mutable nature of the World Wide Web, these may not function correctly
for very long. If the server addresses change, or the HTML interface changes substantially, these
will no longer work correctly. They can possibly be updated by placing the newer web page
locally into the BioEdit/apps folder under the same name as the current ones, but whether they
work correctly will depend upon whether necessary URL references in the web page are specified
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as absolute or relative paths, and whether they depend on calling local CGI or Java programs, and
other such potential problems.

The interface to configure command-line analysis programs does its best to be as complete as
possible without requiring a complicated general-purpose scripting language. Because of the
static nature of thisinterface and its options, however, there will be programs that just cannot be
run correctly through BioEdit, though most programs that accept a command line should be able
to be configured. Many people may prefer to run a program from the command line for better
control of the options, anyway. The accessory application configuration is mainly intended for
labs that want to be able to set up an easy method for several people who grew up on easy GUI
interfaces to be able to run routine analyses without having to navigate the files and command-
line options manually.

BioEdit performs fairly well with reasonably-sized alignments. However, there is an imposed
[imit on both the number of alignment documents that can be opened at once, as well asthe
number of sequences that can be contained in asingle alignment. Currently the limit on open
alignment documentsis 50, though this may run Windows out of resources. The limit on the
number of sequencesin an alignment is 20,000.

The sequence number limit is independent of the lengths of the sequences. The absolute size of
an alignment matrix is limited only by available system memory. If adocument runs the system
completely into virtual memory, editing will become very slow. If alignments on the scale of
severa thousand rRNA genes, or sequence lists from entire genomes, for example, will be used,
it isrecommended to have at least 64 to 128 Mb on aWin95/98 or NT machine, and probably at
least 128 Mb on a Win2000 machine.

The open document and sequence number limits are aresult of poor original program design that
isalittle cumbersome to change at thistime. When the core of BioEdit first evolved, | was still
getting a handle on memory handling and pointer manipulations, and so a static array of pointers
to keep track of open documents by memory address or index is allocated at program startup, and
at the time of creation of a document, an array of pointers to hold sequences that can be accessed
either by memory address or array index is set aside. If this part of the coreis ever redesigned,
there will be no restriction on sequence number nor document number.

Another potential drawback that becomes evident with very large documentsis that al lists of
sequences are treated as an alignment matrix and the entire matrix is kept in physical memory for
every open document. Having three documents open that are each 8000 or so sequences of about
4000 bases long each, for example, will run memory just for the alignment matrices up to >96
Mb, which, on top of the OS and all other allocated memory, will run into virtual memory even
on amachine with 128 Mb RAM, and performance will slow to acrawl. At thistime, thereisno
monitoring of memory use, nor internal swap-file system to reduce physica memory usage of
idle matrix space.

The undo option islimited to one level at this point and needs to be redesigned (this probably
won't happen, though). One undo level requires the same amount of memory as the entire
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alignment, and was admittedly programmed for ease of programming rather than performance.
Therefore, for an alignment matrix where N x M > 40,000,000 (N = number of sequences and M
= length of the longest sequence), undo is automatically disabled.

One more limitation is that BioEdit is written in Borland C++ Builder and is 100% Windows-
based. Itisbasically non-portable asitis. Since the mgjority of this program isits rich graphical
interface, creating asimilar program on UNIX or Mac would require the program be written
almost from the ground up, with very little porting possible.

Contacting the Author
The author can be reached at (at least until March, 2001):

Tom Hall

Department of Microbiology
North Carolina State University
4525 Gardner Hall

Box 7615, NCSU Campus
Raleigh, NC 27695
919-515-8803

tahall2@unity.ncsu.edu
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General Use of BioEdit

Sequence Editing / Manipulation

Manual alignment of sequences

Below is an image of the basic BioEdit alignment document window.
Don't worry if you don’t like the current view. The font, size, background color, residues colors,
and title window width may all be changed. The yellow box to the lower right of the mouse
arrow shows the absolute position in the current sequence. This also appearsin the “ Position”
caption on the control bar, and the option to shut off the yellow boxes is found under
View->show sequence position by mouse arrow.

:)_}"‘BinEdit Sequence Alignment Editor - [C:ABioEditDev\Ribosomal BMAVIES_RMNA_prokaryotic.bio]

%Eile Edit Sequence Afignment View ‘wWorldWide'web Accessorp Application BMA Ophon:  Window  Help -8 x|

o] |
El ICnurierNew jlm jﬂ‘ 5205 total sequences

b ode: - Selection: 0 Sequence Mazk: Ezchenchia coli str. MGTES5 loene Siart
o IGrab b Drag J Position; 3371: Citrobacter freundii 795 Numbering Mask; Escherichia cali str. MG1655 lasne ruler at]!

Alo(ialalfele el BN ]

zpeed slow

ia amvlo
Citrobacter f1jEs
Cocos nucifer: [
Mycetome endo: S
Mycetome endo: s
Mycetome endo: S
Mycetome endo: s
Mycetome endo: S
syibiont of C: s
svibiont of C: s
symbiont of C: s
svibiont of C: s
secondary end:; s L e ] :
svyibiont of 5 [ES B-GATTR L3 A -G G LRAL

1II P

The general manual alignment functions are:

kade: | E dit j

Select / Slide
(Edit

[arab & Drag :

There are three basic modes available in the edit window: EI
These options may also be found under Sequence->Edit Mode
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Select / Slide mode: Select residues by boxing them with the mouse (left mouse button). Drag
the selection back and forth with the mouse. The default isto “crunch” unlocked gapsin the
direction you are diding and open new unlocked gaps on the other side of the selection. To
move the entire sequence downstream of the selection, regardless of gaps, hold down the shift
key while dragging. 'Y ou may also toggle the appropriate button on the buttons panel (see below)
to change the default to moving the entire sequence downstream of the selection. With this
option selected, use the shift key to “crunch” unlocked gaps when dliding.

Using the shift key while selecting will select all residues between the current selection and
new selection. The CTRL key allows you to add only the new selection to the current selection
(for instance, you may want to select residues in three sequences which are not right next to each
other).

Edit mode: When in edit residues mode you may place the cursor anywhere in the document
(except thetitles) and type. Y ou may move around between sequences with the arrow keys.
There are two basic modes of editing, asin aword processor: insert and overwrite. When the
editor isin "Edit" mode, achoice will be visible to the right of the edit mode drop-down:

hdode:; I Edit j Dverwritej

<l s T

(L wenarite

When in the other two alignment modes, this choice will not be visible.

Grab & Drag mode: Choosing “Grab & Drag” from the “mode” list or toggling the “ G/D”
button (see below) alows you to grab and drag a single residue dynamically on the screen. Use
the shift key to move the entire sequence downstream of the residue (or toggle the appropriate
button on the buttons panel -- see below).

Grouping of sequences. Sequences may be grouped into groups (or "families’). The alignment
for agroup of sequences may be locked together, meaning that hand adjustments (insertion
and/or deletion of gaps by dliding residues) will be automatically synchronized for alocked
group. Thisonly appliesto dliding resides (Select / lide mode or Grab & Drag mode), not to
single insertions and deletions of gaps with right mouse clicks. For information on grouping
sequences and locking the alignment of groups of sequences, see grouping sequences.
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Tool Bar / Speed buttons:

ifl Lock and unlock all gapsin the entire alignment (shows all unlocked position). When an
alignment is opened, this button isin the unlocked state, but gaps are present however they were
saved. Changes are only made each time this button is pressed. To unlock all gapsin a current
alignment, you must press this button twice to toggle it back to this state ( the first press will lock
al gaps).

8 Locked state of above button.

When down, allows you to insert single gaps by right-clicking the mouse.

Delete gaps by right-clicking the mouse.

Insert gaps in all sequences except the one clicked on with the right mouse button.

Delete gaps in all sequences except the one clicked on with the right mouse button.
Sequences that do not have a gap at the selected position will be unchanged, but the gap will still
be removed from any sequences that have one there.

Reverses the default functions of the left and right mouse buttons

g oo

1 Toggle “Grab & Drag” mode.

¥ When this button is down, the default when dliding residuesis to crunch or expand
downstream gaps. Use the shift key while gliding to reverse this.

E When this button is down, the default when dliding residues is to move the entire sequence
downstream of the selection, rather than crunching or expanding gaps. Use the shift key while
diding to reversethis.

@ Normal view mode. When sequences are viewed in color, residues are colored according to
the current color table. This option must be chosen to view sequences in monochrome. All other
views override monochrome viewing.

ﬂ Inverse color view mode. Background boxes are shaded according to the color table for
each residue. Residue colors are the inverse of their normal colors.

@l “Strength of Alignment” -- Residues are shaded in grayscal e according to the information
content at each column position.

ﬂ| Residue backgrounds are shaded according to the information content at each column
position.

ﬂ Shade residues by identity and similarity in the document window. When this button is
down, adrop-down list will appear on the control bar which controls the percent threshold for
shading. The matrix file used for similarity shading of protein alignments can be specified from
the Alignment->Similarity Matrix menu.

ﬂ Draw features with sequences superimposed over them.
ﬁ Draw features only. Do not show sequences.
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AT
CAT

GAT
CAT

mod

TTHE
SR

|r|

View sequencesin color, according to the current color table.

View sequences in monochrome, according to the currently selected sequence color. This
e only appliesif the “normal view” button is also down.

Show identities to a reference sequence (default = top) with a character (default =".").

Tl

This drop-down allows for selection of the character to plot identities with, provided that

the previous button is active (depressed).

= |2

Show or hide the mutual information examiner (for RNA analysis only).

Brings up the color table edit dialog.

Toggles “ignore anchor points” mode. When thisis off (the button is not down), column

anchors restrict the range of aignment. When this button is down, column anchors are ignored.

Scroll L1 |
speed sl fast Scroll speed controller: controls the speed of the horizontal scroll bar

(scrolling isin increments of residues).

Al Add or remove a positional marker flag.
& Add or remove a column anchoring point.
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Editing in an Edit Box

To make major edits to a sequence, it may be convenient to edit it in atext window. To open
an edit window for a sequence, either double-click on the sequence title, or select the sequence
and choose “Edit Sequence” from the “ Sequence” menu. For changesto take effect, the “ Apply”
or “Apply and Close” button must be pressed. Canceling will cause no change in the sequence.
The following window will appear when a sequence is first opened for editing.

:?j"Edit E. coli Oxy R: C:ABioEditDev\Ecoli_OxyR_gb !E[
MName: |E. col Oxy R Sequence Type: [Protein =]
Length: 305 Fosition: 1
True Length: 305 True Position: 1
Font Size:lm "I Cequence: 1 out af 1 [~ Lock sequencelﬂ\-‘erwrite j

-
10 =0 20 40 EO Eﬂj
P T T T T [ T e T |

miiirdleyly alaehrhfrr aasdschvagr tlsggirkle delogvmller tCesrkwlftoa

T AN (PP TR o DUUU T e U T L I
gmllvdogart vilrevkwlke masdogoetms gplhiglipt wogpyllphii pmwlhogtfokl

lISIII : lI4III : l,IEIII : llISIII : l'II-‘III : l:IEIII
emylheagqth gllagldsgk ldovilalvk eserfiewvpl fdepmllaiy edhpuanrec

lT‘:JEI : ZIIIIEI : Z.II.III : ZIZEI : ZISEI : 2|4III

wiomadlagek llmledghel rdgamgfcofe agadedthfr atsletlrnm wvaagsgitll lI

Apply | &pply and Close | Cancel | ﬂ [+ Colar

In the " Sequence Type" drop-down, the following options are available. If asequenceis
"unknown", the protein color table is used for coloring, and it is treated like a protein sequence
for the purposes of similarity shading.

-

MHucleic Acid

Comments

A "comment" may be reserved to hold information on the screen at any line in the alignment, but
does not contribute to calculations of similarity and identity, and is not subject to the standard
manipulations such as translation, complementing, automatic alignment, etc.

Y ou may choose to lock any sequence with the "lock sequence” option within the single

sequence editor. ¥ Lock sequence
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When this option is applied, editing on screen and hand alignment by selecting/dragging or grab
and drag will be disabled. Adding and deleting of gaps by right mouse clicks will still be
enabled, however.

To expand the window to see associated GenBank information, press the ﬂ button
The window will expanded as follows:

:ﬁ"Edit E. coli Oxy R: C:ABioEditDev:\Ecoli_0OxyR_gb

MName: |E. col Oxy R Sequence Type: [Protein =]
Length: 305 Fosition: 1
True Length: 305 True Position: 1
Fant Size:lm "I Sequence: 1 out of 1 [~ Lack sequencelﬂverwrite j

10 =0 20 40 5o &0
P T T T T [ T e T E |

miiirdleyly alashrhfrr aadschv=adgpr tlsggirkle delogvmller tsrkvwlftoa -
Apply | Apply and Cloge | Caricel | ﬂ [ Color

LOCLS: LOCUE 73069 305 aa 16-FEE-1

DEFIMITION: [DEFIMITION regulatary pratein oxpR - E zcherichia cali,

ACCESSION: [73062 FID ar MID: |-;r?3|:|59

CESOURCE: [DBSOURCE  PIR: locus RGECOX

KEYWORDS: |FEYWORDS DMA binding; transcription requlation.

Ll._

R 2 3
plelelv[v]v |¢

SOURCE: SEI'I:IﬁEEH .E En::hnlarin::_hila_ n::n:nli.l_

REFEREMCES: HEFEHET;IEE ,J _[r_esidu:alsj tDH_SEIE]H _
COBEMT:

FEATURES: |FEATURES Location/Qualifiers

The II button may be used to bring up the associated field in a larger edit window.
** Note: GenBank information will only be saved in GenBank or BioEdit format

***Note: GenBank information, including the "features’ field, isinternally independent of user-
defined graphical annotations.
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Windowshading

A document may be “Window shaded”, that is, reduced to itstitle bar, by double-clicking on
the title bar of the window. Double-clicking again will bring it back to itsoriginal size. It can
also be minimized and maximized in the norma manner.

Adding a new sequence
A new sequence may be added by:

1. Selecting the “New Sequence” option under the “Sequence” menu. The sequence may be
typed, or copied as raw text, into the sequence window. Press“Apply” to add the sequence to the
document.

2. Sequences may be copied and pasted from other BioEdit documents with the “Copy
Sequence(s)” and “ Paste Sequence(s) commands from the “Edit” menu. Also, current menu
shortcuts may be used (defaults: Ctrl+F8 for copy and Ctrl+F9 for paste).

Editing on screen
Sequences may be edited on screen much like working in aword-processor. The “Mode”

option of “Edit Residues’ must be set first (BioEdit isinstalled with the “ Slide Residues’ mode
asthe default).

37 C:\BioEditDev\bacterio.bio

El IEourierNew jlm jﬂ‘ & total sequences

Mode: i Selection: nul Sequence Mask: None Shart
o w Position: 15 Murmbering Mazk: Maone iler at: 1
— | Select / Slide

Lo | 5 | ool -+ e [ M NN e ] BT 4

When in edit mode, you may use the arrow keys to move around on the screen and type asin a
text editor. There are two options for editing: Insert mode or overwrite mode, which each
behave as the anal ogous functions in a common word-processor.

Selecting Sequences

Sequences are selected by clicking on their titles. Multiple sequences may be selected by
drawing a box around them, or by shift-clicking to select everything between two selections. Use
the Ctrl key with the mouse to de-select selected titles, or to add specific titles to the selection.
Double-clicking on atitle will open the single sequence editor. Clicking again on a previously
selected title will put it into on-screen editing mode. Y ou may then edit the title and either press
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<return> or click the sequence title panel anywhere off of the current title for the change to take
effect.

Moving Sequences

To move a sequence (or sequences), select it (highlight itstitle by clicking it with the left
mouse button) and drag it to where you would like it in the alignment.

Cut/Copy/Paste

Copy:

Text in edit window (sequence residues): Select the text with the mouse and choose “Copy” from
the “Edit” menu. Unlike aword processor, you may copy discreet blocks of text without copying
entire lines of text. A block of text copied this way may be pasted into any text edit-capable
program.

If, and only if, there are no residues selected in the entire document, sequences whosetitles are
selected will be copied as BioEdit sequence structures to the BioEdit clipboard as well so that the
entire sequence(s) may be pasted into a document by choosing Paste Sequence(s).

Entire sequences: Select the sequence title(s) with the mouse and choose “ Copy Sequence(s)”
from the “Edit” menu. Seguences whose titles are selected will also be copied to the Windows
Clipboard in Fastaformat. More than one selected sequence will be copied to the clipboard as a
Fasta sequence list, and copied internally within BioEdit as a group of full BioEdit sequence
structures that can be pasted into any BioEdit document.

Note: The BioEdit "clipboard” which contains all sequence-related data (GenBank information,
graphical annotations) isinternal to a single instance of BioEdit (they cannot be transferred
between independent processes). To copy sequences between BioEdit alignment documents,
make sure to have both documents open within the same instance of the program, as only Fasta-
formatted sequences are copied to the general Windows clipboard.

Paste:

Text in edit window: To paste into a sequence within the main edit window, the interface must
bein “Edit Residues” mode (see Editing On Screen). If ablock of text is pasted into a sequence,
only the first line (defined by a carriage return) will be pasted in. Thisisto avoid possible
problems with pasting text into one sequence and inadvertently corrupting sequences below it.
To paste segments of text into ablock of an alignment, segments must be pasted into sequences
one at atime. If thedocument isin “Slide Residues’ or “Grab and Drag” mode, then Paste will
behave the same as Paste Sequence(s) (see below).
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Entire sequences. From the menu of the document to paste sequences into, choose “ Paste
Sequence(s)” from the “Edit” menu. The sequence(s) will be added to the end of the document.
They may be then be moved to somewhere else within the alignment.

“Cut” and “ Cut Sequence(s)”: Same as“ Copy” and “Copy Sequences’, but del etes copied
information from document. Residues are only deleted from the document if “ Edit Residues’
mode is active, however. Also, when Cut is used when no residues are selected in the document,
sequences whose titles are selected are copied to the BioEdit Clipboard as sequence structures
and to the Windows Clipboard in Fasta format, but they are not deleted from the document. To
properly cut sequences from a document, choose “ Cut Sequence(s)”.

Minimizing an Alignment

When an alignment is manipulated and tweaked extensively by hand, and when sequences are
periodically added to an existing alignment and aligned manually, gaps often result which are
present throughout a column in every sequence. To remove gaps that don’t change the actual
alignment, simply choose “Minimize Alignment” from the “Alignment” menu.

Basic Manipulations/ Sequence Menu

There are afew simple sequence manipulations which can be done automatically with
BioEdit with a single menu option. These options are found in the “ Sequence” menu.

Masking in BioEdit is at this point alittle weak, and is provided mainly for use with the RNA
comparative analysis functions. For an explanation of how BioEdit uses masks, see Masks.

Lock and unlock gaps: A locked gap will not be compressed when residues within a sequence are
did. Tolock gaps, select the gaps to be locked and choose “Lock Gaps’. To lock all gapsina
sequence, select the sequence title, then choose “Lock Gaps’. To lock al of the gapsfor an

alignment, toggle lock/unlock button to the locked state: ﬁl

Unlocking gapsisjust the reverse of locking them. To unlock all gapsin an alignment, toggle

the locked/unlocked button to the unlocked state: g’

The “Degap” option will remove al selected unlocked gaps. It will also remove and all unlocked
gaps from sequences whose titles are selected.

Note: '~ and . (tilde and period) represent unlocked gaps, and '-' (dash) represents alocked gap.
These conventions are used throughout every window and function in BioEdit. A period isnever
produced by BioEdit to represent a gap character, but is treated as atype of gap for computability
with programs that prefer this character. Also, some programs may use a period to represent
alignment positions that are neither residues nor gaps, but simply fill alignment slots before the
beginning or after the end of a sequence. BioEdit does not directly pay attention to this
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distinction. Positions before or after a sequence's range are treated as gaps and BioEdit assumes
each alignment consists of truly homologous sequences (although BioEdit is also designed to
allow the user to ignore the alignment focus of the program and use it ssmply to manipulate lists
of sequences).

Sequence Menu (excluding the “mask” functions)

New Sequence: Create a new sequence. This opens up the single sequence editor
Edit Sequence: Opensthe first selected sequence in the single sequence editor

Select Positions. Opens adialog that allows selecting of specified positionsin all selected
seguences.

Open at cursor position: If the document isin edit mode, and the cursor is showing, this
option will open the sequence with the cursor at the cursor’s current position in the single
sequence editor.

Rename: Rename sequence titles according to a submenu option:

Edit title: Change thetitle of a sequence on-screen.

with LOCUS: Change al selected titlesto the LOCUS field.

with DEFINITION: Change all selected titlesto the DEFINITION field.
with ACCESSION: Change all selected titlesto the ACCESSION field.
with PID/NID: Change all selected titlesto the PID or NID field.

Sort: Sort sequences according to the following criteria:

By Title

By Locus

By Definition

By Accession

By PID or NID

By Reference

By Comment

By residue frequency in a selected column

When the latter option (by residue frequency) is chosen, a single column of residues must
be selected, and the sort is performed by order of greatest frequency of residues defined as
valid residues.

Pairwise alignment: Optimal alignment of two sequences
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Align two sequences (optimal GLOBAL alignment): Align two sequences optimally with
aglobal alignment algorithm based upon the Smith and Waterman optimal alignment
method.

Align two sequence (allow endsto slide): Align two sequences optimally with alocal
alignment algorithm based upon the Gotoh modification of the Smith and Waterman
optimal alignment method which does not constrain the ends of either sequence (either
sequence end is allowed to slide freely over the other sequence). This alignment tends to
be very useful for quickly identifying overlapping regions of sequence reads in small
sequences where an auto-contig assembly program is not required.

Calculate identity/similarity for two sequences. Calculates the identity and similarity

(according to the current similarity matrix) for two sequences as they are currently
aligned in the document (does not align them).

Similarity Matrix (for pairwise alignments and shading): These matrices apply to amino acid
sequences only. BioEdit does not use any matrix scoring schemes for nucleic acids (only simple
identity).

BLOSUMG2: The default matrix used by BLAST. The BLOSUM matrices are generaly
good for database searches and assume moderately large evolutionary distances (smaller
BLOSUM number = greater evolutionary distance -- only the BLOSUM 62 matrix
[intermediate] is supplied in BioEdit).

PAMA40: Intended for very closely related sequences (40 PAM units = relatively small
evolutionary distance -- in the PAM matrices, large PAM number = greater evolutionary
distance).

PAMS80

PAM120

PAM?250: Intended for more distantly related sequences (larger PAM distance).

IDENTIFY: Simple match or mismatch matrix with avery large (-10000) penalty for
mismatches

DAYHOFF. Actualy a PAM250 matrix -- M.O. Dayhoff's original PAM 250 matrix
(each value rounded to the nearest integer).

MATCH: Simple match or mismatch matrix with a-1 penalty for mismatchesand a+1
score for matches.

GONNET: A modified PAM 250 matrix recommended by Gonnet (1992).

Features (Feature annotation functions):
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Automatically annotate from GenBank Feature Fields. This option allows you to add
features according to the pre-existing GenBank data already deposited for the sequence.

Edit Features: Add, modify or delete features in a sequence.

Annotate Selection: Add afeature that will span the currently selected positionsin all
sequences with a selection in them.

Annotate selected sequences using the first sequence as atemplate
Sequence groups (or families): Group and ungroup sequences and edit current groups.
Edit Mode: Setsthe current editing mode. See Manua alignment of sequences.
Mask (covered above).

Toggle color: toggles coloring of single sequences. Thisis aleft-over of an early version and is
pretty useless.

Gaps:
Lock gaps, Unlock gaps and Degap: explained above.

Insert multiple gaps. insert a variable number of gaps at the currently selected position in
the alignment window.

Manipulations. Simple manipulations that are independent of sequence type.
lowercase and UPPERCASE: Asindicated -- sequences only, not titles.
Reverse: Reverses any sequence

Remove numbers. Asindicated. Thiswas added by request to ease the process of
pasting partial sequences from GenBank formatted text files and web pages.

World Wide Web:
Automated links are provided to the following selected WWW search functions:
BLAST, PSI-BLAST and PHI-BLAST.
Prosite profile and pattern scans
nnPredict protein secondary structure prediction

Nucleic Acid:
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Nucleotide Composition: Plots nucleotide composition and gives a summary including
G+C and A+T percentages and molecular weight

Complement: The complement of aDNA or an RNA sequence. This option has no
effect upon protein sequences, and characters other than the standard five bases (A, G, C,
T and U) and purines/pyrimidines are not affected (the complement of apurine (“R”) is
apyrimidine (“Y™")).

Reverse complement: Behaves the same as complement, but also reverses the sequence.

DNA->RNA and RNA->DNA: These really do nothing but toggle “T"’sand “U"’ s and
change the sequence type.

Trandate: Trandate sequenceinframel, 2 or 3, or trandate the currently selected region
of aseguence. Codons are separated by spaces. The nucleotide sequence is shown on top
of the protein sequence. The translated sequence is specified by three-letter or one-letter
amino acid codes, depending on the preferences. If a selected part of a sequenceis
translated sequence is transated, either the entire nucleic acid sequence or only the
trandlated region may be displayed, depending on the current preferences. A summary
table may be displayed below the translation which shows the number of times each
codon appears in the sequence, as well as the frequency with which each codon codes for
a particular amino acid according to the codon table provided.

Find Next ORF: Searches the currently selected sequences from the point of the last
current selection for ORFs according to the parameters defined in the preferences.

Create plasmid from sequence: A DNA sequence may be converted directly into a
plasmid/vector. A restriction map is automatically run on the sequence. For help on
annotating a plasmid, see Plasmid drawing with BioEdit

Restriction Map: Run arestriction map on a DNA or RNA sequence.

Sorted and Unsorted six frame trandlations. Translate nucleic acid sequencesin all six
frames by specifying a start codon (ATG, “any”, or user-defined), and a minimum and
maximum ORF size. Sorted translations are limited to afew thousand output ORFs. To
get araw trandation of entire genome (or larger), use an unsorted trandation (in an
unsorted tranglation, the output datais printed directly to afile, and very little memory is
required).

Protein:

Amino Acid composition: Gives a plot and summary of the amino acid composition of a
protein, including the molecular weight.
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Hydrophobicity profiles:

Mean hydrophobicity is calculated by the method of Kyte and Doolittle (1982) using
achoice of hydrophobicity scales.

Hydrophobic moment is calculated according to the method of Eisenberg et. al.,
1984). The algorithm of Eisenberg et. al. for finding transmembrane alpha helicesis
not applied here, rather the hydrophobic moment of a user defined segment of
sequence is plotted for each residue (each residue represents the beginning of a user-
defined segment);

Mean hydrophobic moment: For each residue, the mean hydrophobic moment for a
window the same size as that used to cal culate each hydrophobic moment is applied.

Note: | do not have the expertise to make any claims about the predictive power of
these profile plots. BioEdit makes no conclusions about hydrophobic and/or
transmembrane segments of proteins, and interpretation of these plotsis up to the
judgment of the user.

For a description of the method and meaning of these plots, and references to the
hydrophobicity scales and to hydrophobicity analysis agorithms, see Hydrophobicity
Profiles.

Trandate or Reverse-Trandate: Translation from DNA or RNA to protein is done according to
the codon table specified in the BioEdit.ini file. The default is“codon.tab” found in the /tables
directory. The default isthe E. coli codon usage table produced by J. Michael Cherry
(cherry@frodo.mgh.harvard.edu) with the GCG program CodonFrequency. Any codon table
with this format may be used, but the codon table must be in this format to be recognized by
BioEdit. To choose adifferent table, see Codon Tables. A protein sequence will be degenerately
encoded (to DNA) based upon codon preference for each particular amino acid. Obvioudly, if a
nucleic acid sequence is translated to protein and back, information will be lost.

Trandatein Selected Frame (Permanent): This allows you to trandate a nucleotide sequence
asif the currently selected column (defined as the start of a selection if more than one column is
selected) isframe +1. When applied to a protein sequence, it simply resultsin the same
degenerate reverse trand ation as the above option.

Toggle Tranglation: Toggles nucleotide sequences between the nucleic acid and encoded
protein sequences, allowing for alignment of the sequencesin either view. See Toggling between
nucleotide and protein views

Toggle Trandlation in selected frame: This option allows you to toggle the trand ated view

(without losing any nucleotide information) asif the currently selected column (defined as the
start of the selection if more than one column is selected) wasin frame +1.
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Dot Plot (pairwise comparison): Create adot plot of two sequences compared to each other in
amatrix.

Customizing the View
BioEdit currently supports the following view options:

» Background colors for sequence and title windows

» Default monochrome sequence and title colors

* Character fonts.

* Fontsize

* View sequences in bold-face type.

* View sequences in monochrome or color (editing is faster in monochrome).

* Normal color view (residues colored)

* Inverse (background colored)

e Strength of alignment: shading is based upon the information contained at each position --
information is calculated as follows:

*  DNA/RNA: information = In5+2 fbx[In(fbx)])

* Protein: information = In21+5 fox[In(fbx)]),
where fbx represents the frequency of each residue b occuring at position x. 5 represents the
number of possible residues for nucleic acid (4 nucleotides plus gaps). Thisisnot quite right,
and the usefulness decreasesif alot of alternative characters are used. 21 represents the
number of possibilities for amino acids (including the gap). In5 and In21 are the maximum
information for anucleic acid position or a protein position, respectively and the term
-2 (fbx[In(fbx)]) represents the entropy (a measure of variability) at the position.
The above description was true of BioEdit versions before 5.0.0. In BioEdit version 5.0.0,
only the user-defined valid residues contribute to the entropy calculation. In this case, gaps
only contribute to the calculation of entropy if they are defined as valid residues (or place-
holding characters, if you'd rather think of it that way, asit is obvious that a gap cannot be a
residue).

» Strength of Alignment - Inverse: Same as Strength of alignment, but the background instead
of the residue is shaded.

* ldentity/Similarity shading: Residues are background-shaded with there color-table defined
colorsif their frequency in a column equals or exceeds a user-defined cutoff (the option to
choose the cutoff goesin increments of 10% and is visible when this mode is active).
Nucleotide alignments are shaded according to identity only, while protein alignments are
shaded according to identity and similarity according to the currently selected amino acid
similarity scoring matrix. Only characters defined as valid residues and only non-comment
sequences contribute to the similarity and identity calculations.

»  Sequences and Graphical Features. Draw graphical sequence annotations on the document
screen with the sequences superimposed on top of them.

» Graphical Features. Draw graphical sequence annotations in cartoon mode and do not draw
the residue characters. When this mode is active, thereis a scale-factor slide bar toward the
top of the window that enables a scaling factor between 1:1 and 1:32768, by orders of 2.
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* Conservation plot: Residues are plotted as a user-defined character (default = a period) if
they are identical to the residue in the same column as a user-defined standard (default = the
top sequence). To change the standard (reference) sequence, right-click the sequencetitle
with the mouse that you want to be the new standard for the conservation plot. Only
characters set as valid residues are recognized for the identity plot.

»  Show or hide the mutual information examiner (thisisonly useful for RNA comparative
anaysis).

* Show or Hide the trandation toggling control. Thisis mutually exclusive with the mutual
information examiner control, because of space limitations.

»  Show seguence position by mouse arrow: when moving the mouse over sequencesin a
document window, the absolute position of the mouse (ignoring gaps) is reported on the
control bar above the sequence view window. The position may also e reported (including
the full length of thetitle) at the mouse arrow. This option turns this feature on or off.

* Split window vertically: A duplicate window is created which sits inside the document
window and is synchronized with the current document. The window is placed such that the
document appears to be split by a vertical window splitter (it's really just two synchronized
documents, one with most of it’s interface removed). The vertical scroll position of the two
windows stays in register, but horizontal scrolling in each isindependent of the other. The
window may be resized by grabbing the window splitter within the main document. The
window may be returned to normal by choosing this menu option again.

» Split window horizontally: A synchronized window is created which is placed directly below
the original window such that the border between the bottom of the original window and the
top of the new window behaves like a window splitter. Remove this window by choosing the
option again.

» Saveoptions asdefault: When * Auto-update view options’ is off, choosing this item will
save the view options of the current document as the default for all newly created or newly
opened documents.

» Auto-update view options: when thisitem is checked, all changes made to the document
views and preferences are automatically saved as the default for new documents.

»  Customize menu shortcuts: brings up adialog that alows changing of menu shortcuts to any
key combination.

* Hide control bar or Show control bar: The main control bar may be removed in order to fit
more sequences on the screen in asimple frame window. If the control bar is hidden, then
the “ Show control bar” option is offered. If the control bar is hidden, sequence editing
modes may be changed through the Sequence->Edit Mode submenus. View defaults may be
changed viamenus as well.

To change these settings, choose the appropriate option from the “View” menu of an open
document. To make the current view from any particular document into the default view for all
subsequently opened documents, choose “ Save Options as Default”.

These views may be selected either through the “View” menu or by pressing the appropriate
speed button on in alignment window.
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Color Table

One color tableisused for all documents. Thistableiscalled “color.tab” and isfound in the
\tables directory of the BioEdit install directory (see Program Organization). Although the table
may be edited by hand, it is much easier to use the “ Color Table” option under the “ Options”
menu of the main application control form.

Editing the color table: To edit the color table, choose “Color Table” from the “options’ menu of
the main application control bar. Thereisadifferent color table for nucleotide and protein
sequences. To change the color of aresidue, double-click on the colored box above the residue
to get acolor dialog. To add or delete aresidue, click the “+” or “-” button. In the window that
appears, push the button for the residue to be added or deleted. When adding aresidue, it comes
in with black as the default color. The color must then be changed to the desired color.

To edit the color table by hand, the following format must be observed:
» Each color table is denoted by aline containing the exact text “/amino acids/” or
“/nucleotides/” (without the double quotes).
* Theend of each tableis denoted by (exactly) “////I" (without the double quotes);
» Eachresidue color is specified by two linesin thefile:
- Line 1: A 3-byte hexadecimal number (or its integer value). The three bytes represent
the values for blue, green and red, respectively (backwards RGB).
- Line 2: Anunbroken list of all characters representing all characters which should have
thiscolor. If acharacter color is redefined elsewhere in thefile, the last occurrence will
be the valid one.

Note: Manual editing of the color table should not be necessary and is not recommended.

If the color table becomes corrupted, it may lead to program failure on startup or when the color
table is edited. If this happens, you may delete the color table and create a new one, one residue
at atime (you will get an error on startup and on choosing “Color Table”, but the program will
create a new table when the “ Save Table” button is pressed). Thisistedious, so the /tablesfolder
of BioEdit also comes with afile called “defcolor.tab”. If the color table becomes corrupted, you
can make a copy of defcolor.tab and change the name of the copy to “color.tab”.
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Customizing menu shortcuts

Preferred menu shortcuts may be created for any menu item or sub-menu item (but not to a third

level). Shortcuts may only be customized for alignment document windows, however. For
example, if Ctrl+Y was set to be a shortcut for “copy”, when working in the text editor, Ctrl+C

would still be the copy shortcut

To set shortcuts, choose View->Customize Menu Shortcuts. To set a shortcut, ssimply scroll to

the menu item of interest, select it with the mouse, then press the particular key combination you

would like to use to activate it. To completely remove a shortcut, highlight an item and press

“Clear Entry”

:.;" Cusztomize Shortcuts

To customize a shortout, select the menw item and prezs the key(s]
wou would like bo invoke the menu option

Toremowve a shortout, select the ke and press Clear Entry

aFile

aNew Aligrnment
New from Clipboard
alpen ...
New Text
Open As aText
alave
Sawve ghs_ ..
LExport
Sequence Alignment
Translated aligmment {(using CDE features)
Bpliced aligmment {using exon features)
Baw Text
Bich Text with current shaded wiew settings
True sequence positions of selected sequences
GeneBank format with feature annotations for FEATURE
Tmport
Iwport from Clipboard
Merge into Aligument based on a RBeference Sedquence
Merge from Clipboard
LiClose
Eatch ABI to 5CF trace file conwersion

Rat el Rrwarvt af Darnr Sarmicwvca Traca Tiata

Cloze |

Ctrl+M

Ctrl+40

Ctrl+ts

Ctrl+I

P [=1 4

Clear Entry
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Splitting the window view

It may be convenient to edit two different parts of an aignment at onetime. To allow for this,
BioEdit offers two ways of splitting the document into two synchronized windows, one that splits
the window vertically and the other which splitsit horizontaly.

To split the window vertically, choose View->Split Window Vertically. Shown below isa split
view of part of the prokaryotic 16S rRNA alignment. The two sides share a vertical scroll bar,
but scroll independently of each other in the horizontal direction. The window spit may be
resized with the mouse.

EEE:-‘BinEdil Sequence Alignment Editor - [C:ABioEditDev\Ribozomal BMAA165_BMNA_prokampotic._bio]

%" File  Edit Sequence Algnment Yiew ‘Worldwideweb Accessory Application BMA - Options  Window  Help _|5’|1|
Bl |
|| 8| [Coweries =f10 5] B” 6205 total sequences [shads thisshold 70 % 7]
Made: | E di v e | Selection: 0 Sequence Mask: Eszcherichia coli str. MG1655 [aene Stant
oce:[Edt | CET s Legionela longheach 26( Numbering Mask: Escherichia coli st MG1655 faene ruler at)!

| 1|0 |T| 5| 6 enfl-+ o el mas oD O e B S g

||||||||||||...||||.|||.|||.|.|.|..| ||||.|||.|||||||||..|||||||||.|.|.|||.| =
7 750 J

Fluoribacter bozemar'UUG'
Legionella parisien:z @GUUGE
Legionella anisa LT gUUTGE
Legionella anisa NCTEUTGE
Fluoribacter bozemargUUcA
Fluoribacter hozemar GUUGE
Fluoribacter hozemar [GAUG
Fluoribacter bozemar gUIUTGC
Legionella gratiana KUUGL
Legionella longheact@UWGE
Legionella sainthe le GUUGE
Legionella sainthele GUUGE
Legionella cincinnar[§UUGE
Legionella cincinnat GUUGE
Legionella santicruc§iUG
Legionella steigerwe [§UiUGE
Legionella steigerws GUUGE
Legionella tucsonens @GUUGE
Legionella lytica stgUUGL
Legionella sp. str. {UUGE
Legionella lytica st@UTGE
IS | v

To split the window horizontally, choose View->Split Window Horizontally. Shown below is
another split view of part of the prokaryotic 16S rRNA alignment. The two windows remain
attached, but have independent vertical and horizontal scrolling
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“ BioEdit Sequence Alignment E ditor

File Edit Sequence Algnment Yiew ‘Worldwide'web Accessomp Application BMA  Options  Window  Help
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SN I _ I

Sorting Sequences

Sequences in an alignment document may be sorted by the following criteria:

o Title

e LOCUS

e DEFINITION

e REFERENCES
e« COMMENT

e ACCESSION
 PID/NID

» residue frequency in a selected column

To sort sequences, choose " Sequence->Sort-><sort type>
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Graphical Feature Annotations

It is sometimes convenient to have information about certain elements of a sequence (e.g.,
exons, introns, helices, motifs, etc.) available for reference in a quick and easy way, without
going to external sources such as a notebook, other files, or sourcesin the literature or on the
WWW. For this reason, functions allowing for the graphical annotation of sequence features
were added in version 5.0.0. Annotations may be done by hand, or automatically from existing
GenBank format FEATURES data. Names and descriptions for features that span any position in
a seguence are available right in the aignment window as Tool Tips when the mouse arrow is
moved over the sequence residues. The standard GenBank format feature types are used as a
basis for internally keeping track of the sequence "type". If oneiswilling to adhere to GenBank
standards when defining the "description” of each feature, the feature annotation functions of
BioEdit can also provide a convenient way to annotate a sequence, or set of sequences, which can
be exported in standard GenBank format using the user-defined graphical featuresto fill in the
GenBank FEATURES field. This can be a useful starting point for a sequence submission using
Sequin or Bankit.

When afeature is added to a sequence in BioEdit manually, the "true" positions are
calculated and assumed to take precedent over the absolute positions in the alignment, and all
future alignment adjustments are handled with these "true" positionsin mind. For example, if 5
gaps are deleted within afeature, the end of afeature is drawn back by five in the aignment, but
the absolute number of residues within the feature does not change. If 3 bases are deleted within
the feature, the actual end position of the feature will be moved back by three. Likewise, when
features are added automatically from GenBank information, the positions in the alignment
which correspond to the true start and end of each feature are calculated and updated to reflect
the correct aligned state of all elements. BioEdit alows control over the title of the feature, the
color, the shape (rectangular, oval, diamond or arrow), the direction (only makes a difference for
an arrow), the "type" (either "undefined" or any of the 67 standard GenBank feature types), and
reserves space for adescription (unlimited in length).
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Adding, modifying and deleting sequence featur es manually
There are two ways to add or modify sequence features manually:

1. Highlight the sequence title and choose the menu option " Sequence->Features->Edit
Features'. There must be only one sequence title highlighted, or BioEdit will not know which
sequence to edit the features from. The following dialog will appear (which of course would be
empty if there were not yet any features added to the sequence:

ff:-’Edit Sequence Features

Feature | M ame

|l Secitr 1 Dese. [ /nore="helix 2"
fsec_str_tupe="helix"

SeacBtr
SecStr
Secltr
BecBtr
SeacBtr

=1 o L
=1 Thon e LD

Doy

HiS

Start |38 Alignrent start |5'I
End |82 Alignment end |?5
NamelSecStr 2 Shape IFIeu:tangIe j

Modify Colar |
Dielete Type I SecStr j

Add new Cloze |

To add afeature, fill in the "name" box with thetitle of the feature, add a description to the
"Desc." box, and specify either the start and end positions in the sequence as if the sequence were
asimple, unaligned sequence, or, if the sequenceisin an aignment an it is easier to determine
the alignment positions, you can specify those instead and BioEdit will figure out the true
positions for you. If you fill them both in, BioEdit will ignore the alignment positions and

recal culate them based on the true positions specified. Note: If you want afeature to reflect
orientation, and the orientation is reverse, specify the start position as the higher number and the
end position as the lower number. Next, choose a color by pressing the "Color" button (you will
get a color picker dialog), choose the shape, and specify atype under "Type". After this, press
"Add New" to add the feature to the sequence. Note that if two features overlap in position, the
feature further down in the list will be drawn on top of the one further back in thelist. To change
the positions of featuresin thelist, highlight one or more feature titles and press the "Up" or
"Down" button.

To modify an existing feature, click thetitle of the feature on the left and do the same
things as for adding afeature. Instead of pressing "Add New", just press "Modify" (Pressing
"Add New" will effectively duplicate the feature). 'Y ou may modify elements of multiple
features at atime by selecting the titles of all of those features at once. The elementsthat arein
common to all selected features will show up, while those that are not will not show up. If a

ldd
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change is made to any element, and "Modify" is pressed, the change will be applied to all

selected features.
To delete one or more features, highlight the features and press "Delete’.

When finished adding or modifying features, press "Close" at the bottom right of

2. Adding or Modifying afeature from the alignment window:

the dialog.

Adding or modifying a feature from right within the alignment window utilizes aright
mouse-click context menu. For this menu to be available, all of the right mouse-click activated
alignment features must be turned off. This means that the following four buttons must be in the

up position (not depressed):

LIEIEIE If any of these buttons is down, right-clicking in the alignment window will add

or delete gaps, depending upon which button is down.

To add anew feature, highlight the desired span of the feature in the sequence wi

thin the

alignment window. Next, right-click the mouse anywhere over the highlighted section and

choose "Annotate Selection™ in the context menu that comes up.

£ 1 DIDH o2 I EEEHY  $uE
ill""lT"le_é"vl'Tv'zlév"lT"Téé"vl"Tvéévv'lvv"‘éé"vl"

jn¥d

EAQTTSREEWT

MEEEEIEATWLHWLGTAGMEL
EAQTITGREEWNIWLALGTALMET
MLELLETAVESVIQAQTTERPENIWLALGTALMEGT
—MDEITALOQASY--DLLEDERFETLWLETIETLLMLT
—MDEIALTAAVGADLLGDEREETLWLGIETLLMLI
MLOSEMETYVESEEIIF LI VETAGMET
MEAPEGEATWLWLETASMEL

Halohacterium

Move selected bages to left
Move selected bagzes to right
Mark zelected bazes as 'N'
Mark ENTIRE selection with 7'
Mark selected pozitions az "

Haloarsula ar
Halobacteriur
Halohacteriur
Halorubrwum =c
Halobacteriur
Haloarcula =g
Haloarcula wa

Annotate Selection

LITTLVEATAFTIY

Serall LT ]|
speed slow o - fast

'r'r||"r'rr|'r'rr|'0!

&0

ATTILITATAFVNY

NI RN |

|
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The following dialog will appear:

:fj"Edit Sequence Features

D&t Irist coding region

Up
Doy
Startl” [first s2q)  Alignment start |2? (first seq)
End|51 [first seq]  Alignment end |E4 [first seq)
Namelcnding regioh 1 Shape IHectangIe j
Coior
Type | CDS =l
Ok | Cancel |

Therest of the options are the same as in adding a feature manually, but the feature positions are
specified for you based upon the selection in the alignment window. Y ou may annotate a block
selection by selecting a block of residues that span multiple sequences and doing the same thing.
In this case, the same feature will be applied to the same alignment positions in each sequence,
and the "true" positions will be updated independently for each sequence according to the
alignment positions.

To modify an existing annotation, right-click anywhere over the annotation, then choose
"Update Annotation™ (only visibleif you right click over an annotation and only if thereis only
one annotation spanning that region) and you will get adialog like the one above. Pressing OK
will update that annotation, rather than adding a new one. If you simply right-click over the
annotation, the positionsin the dialog will reflect the current begin and end of the feature. If you
make a new selection within the annotation before right-clicking, however, the positionsin the
dialog will reflect the selected positions in the alignment, assuming you want to easily alter the
feature positions. Y ou may also update the same positioned annotations in several sequences at a
time this way by selecting a block, right-clicking and choosing "Update Annotation”.
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Annotating sequences automatically from existing GenBank FEATURES data

Y ou may have BioEdit automatically add feature annotations from GenBank format FEATURES
data, if itispresent. To seeif thereis FEATURES datain a sequence, double-click on the

sequencetitle, pressthe ﬂ button to expand the window, and look at the "FEATURES" box. If
that box isfilled in with data formatted similar to the following, then there is data formatted in
the expected manner for auto-annotating:

Example of formatting in the GenBank FEATURES field:

FEATURES Location/Qualifiers

sour ce 1..247
/ or gani sn=" Hal obact eri um sal i nar unt
[ db_xref ="t axon: 2242"

NonSt dResi due 1
/ non-std-resi due="PCA NH3+"

SecStr 10..31
/note="helix 1"
/sec_str_type="helix"

. etc.

For acomplete list of the tags that BioEdit will look for, either ook in the dialog while using the
program, or see "GenBank Format".

To annotate a sequence automatically, highlight the titles of any sequences you want annotated
(and that have GenBank FEATURES data), then choose " Sequence->Features->Automatically
annotate from GenBank Feature Fields'. You will get the following dialog:

Eﬁ"hnnutate from GenBank Features Field !E[

Dan't Include Ihiclude
Defining Tag Defining Tag

unde fined -
3'clip

Z'UTER

L'elip e e
L'UTE —
-10_sigmal o
=35 _=ignal e

allele ;I

Add Mew Dezcriptor | I

Default shape for features I Rectangle j

[~ Default colar for features |

] | Cancel |

The available tags to search for are on the left. To add atag or tags to the list of tagsto look for,
select whatever tags you would like to be included and press the ">>" button (you can move any
back to the other side with the "<<" button). Y ou can add your own tag to look for by typing it
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into the "Add New Descriptor" box and pressing "Add New Descriptor”, but all of the standard
GenBank tags should be available in the box on the left.

Y ou may choose a default color to apply to all of the features, or you can let BioEdit
automatically choose colors for you (they can be edited later). If BioEdit chooses the colors, all
features of the same type will get the same color. If you choose a default color all features will
be the same color, regardless of type. Y ou may aso choose adefault shape. The default for all
featuresisrectangular. The available shape options are: rectangle, oval, diamond and arrow. |If
arrow is chosen, then the start and end positions are important for determining orientation of a
feature.

When BioEdit adds features, it searches through the FEATURES data |looking for the
specific tags specified in the above dialog. When it finds one (formatted in the proper place), a
new featureis created. Thetitle will be the feature type plus a number reflecting the present
number of that featurein thelist (e.g. "exon 1", "intron 1", "exon 2", etc.). The description will
be all of the descriptive data that follows the tag in the file, including carriage returns to keep the
formatting correct. For example, a CDS feature might have the following name and description:

Name:

CDS 2

Description:

/I abel =b0014

/ gene="dnaK"

/ product ="DnaK protein (heat shock protein 70)"

/ not e="0638; 100 pct identical to DNAK ECOLI SW P04475"
/codon_start=1

/transl table=11

/transl ati on="M3KI | G DLGTTNSCVAI MDGTTPRVLENAEGDRTTPSI | AYTQ
DGETLVGQPAKRQAVTNPQNTLFAI KRLI GRRFQDEEVQRDVSI MPFKI | AADNGDAW
VEVKGKMAPPQ SAEVLKKMKKTAEDYLGEPVTEAVI TVPAYFNDAQRQATKDAGRI
AGLEVKRI | NEPTAAALAYGLDKGTGNRTI AVYDLGGGTFDI SI | EI DEVDGEKTFEV
LATNGDTHLGGEDFDSRLI NYLVEEFKKDQGH DL RNDPLAMQRL KEAAEKAKI ELSSA
QQTDVNLPY! TADATGPKHWNI KVTRAKLESLVEDLVNRSI EPLKVALQDAGLSVSDI
DDVI LVGGEITRVPMWQKKVAEFFGKEPRKDVNPDEAVAI GAAVQGGYL TGDVKDVLLL
DVTPLSLA ETMGGVYMITLI AKNTTI PTKHSQVFSTAEDNQSAVTI HVLQGERKRAAD
NKSLGQFNLDG NPAPRGVPQ EVTFDI DADA LHVSAKDKNSGKEKI T1 KASSGLN
EDEl QKMVRDAEANAEADRKFEEL VQTRNQGDHL L HSTRKQVEEAGDKL PADDKTAI E
SALTALETALKGEDKAAI EAKMQEL AQVSQKL MEI AQQRHAQQQTAGADASANNAKDD
DVVDAEFEEVKDKK"

BioEdit will place the end toward the left (lower number) and the start toward the right
(higher number) for features that are specified as "complement”.

For features that are specified as multiple positions with a"join" command, a separate
feature will be created for each individual start/end position set. In this case, the first feature will
have the full description field. Subsequent features created by the join command will have the
description "join #<number> to <feature type> <number>" (e.g., "join #4 to CDS 2").
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Annotating other sequences based upon an annotated template

If you are dealing with an alignment of homol ogous sequences, chances are good that
features you will be interested in that have to do with the function of the sequence will be lined
up between sequences in abiologically relevant alignment. Therefore, for features such as RNA
or protein helices, functional motifs, or introns, exons and CDS regions, etc. in many, if not
most, aligned sequences it may be only necessary to annotate one sequence with the features of
interest and then, once the sequences are properly aligned, annotate all of the others based upon
the alignment positions of featuresin the annotated sequence. Thisway, even if the actual true
positions and lengths of features differs between sequences, but their relative positionsin a
biologically relevant alignment line up vertically, then annotating correctly aligned sequences
becomes much easier than having to annotate each sequence individually. The true positions for
features created in this way are then cal culated automatically for you by BioEdit.

To annotate sequences based using another annotated sequence as atemplate, first move the
annotated sequence to the top of the alignment, select the titles of all sequences you want
annotated, then choose " Sequence->Features->Annotate selected sequences using the first
seguence as atemplate’.
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Grouping sequencesinto groups or families

Sequences may be grouped together to reflect their relationship by highlighting their titles
with a group-specific color. Also, the alignment for grouped sequences may be locked together
in order to synchronize alignment adjustments to pre-aligned, closely related sequences when
making alignment adjustments based upon new data or added sequences.

To edit sequence groups, choose " Sequence->Sequence groups (or families)”. Y ou will
get the following diaog:

:‘;’ Sequence groups S [=] |
Seguences in group Available zeguences not in a group
iH: n Halobacterium halobium. Haloarcula sp. ARG-2.
Haloarcula Halobacterium zalinarm.
Halorubrum Halobacterium sp.

Halobactenum zp. 5G1.

[A [
ALY

G":'UF'_ ~ |Halobacteriurm species group
Dezcription

 ame IHaII:ll:laI:terium Murnber in group: 0

Calor | [title: color)
Add

[+ Lock alignment [add # remove gaps in all grouped sequences together)
kd adify |

Delete Group(z] Cl
| nze |

Y ou may create groups by typing in the desired group name in the "Name" edit and pressing
"Add". A new group will be created which does not have any sequencesin it. To add sequences
to agroup, select the group titlein the "Group” list and select the desired sequence titles from the
far right list entitled "Available sequences not in a group™ and press the "<<" button. Y ou can
remove sequence from a group by selecting them on the left and pressing the ">>" button. Each
group has a description and acolor. The title backgrounds in the alignment window will be
colored according to the group color if the sequences belong to agroup. Y ou can remove groups
by highlighting them in the "Group" list and pressing "Delete Group(s)"”.
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Verbal confirmation of sequences

If you hand-type a small sequence into the single-sequence editor, for example a primer sequence
to be stored in afile and ordered for synthesis, it is sometimes helpful to have someone read back
the sequence for you as you verify on paper base by base asthey read. If there is nobody
available to read your sequence to you, BioEdit will slowly read a sequence back from within the
single sequence editor, highlighting each base as it goes along (amino acid sequences may be
read as well).

To read a sequence back from within the single sequence editor, choose "Edit->Read Sequence
Back (Press escape to cancel)".

Note: Thisisonly available from the single sequence editor. To open a sequencein the single

sequence editor, double-click onitstitle, or highlight itstitle and choose " Sequence->Edit

Sequence”.
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Valid residue character svs non-residue characters

A researcher may wish to use characters in a sequence which are not defined in nature, that are
ambiguous, or that ssmply hold a position, but are not known to be aresidue or agap. For this
reason, there is an option to explicitly define which characters are considered to be valid for the
purposes of calculations such as similarity shading and generation of an identity matrix. There
are separate lists of valid residues for amino acid and nucleic acid sequences. To see or change
the current settings for what is considered a "true” residue, choose " Options->Preferences-
>General. The following screen should appear:

3 Preferences _ O]

Mutuallnfnrmatinnl Envariatinnl Patential F'airingsl ORF= I Ennsensusl Fairwize &lignment  General |

Characters conzidered to be residues Temp directary for file swapping: Browse |
These residues are included in zimilarity |<Bi|:|E|:|it>'\T —
and in dat dizplapz
Hucleic ﬁc[!lin't Aming '&'Dgnn't Local BLAST databaze directory Browze |

include ~include | Include include | [(ioE > database
A 1 L (IS
c v T c n v Merify revert ta saved
C # ] #
T S E §
- % F %
) & (o) &
~ ! | H 1

{ I {

ﬂ } K ﬂ b
* L *
ﬂ + Hn ﬂ +

. P .

s Q !

u] 23 a

1 = 1

Z T Z

2 w 2

E) M — LY

E T E

1 T

Cancel

The default set of charactersis AGUCT-~. for nucleic acids and
ACDEFGHIKLMNPQRSTVWY -~, for amino acids. By default, gap characters are included,
but may be removed by selecting them on the left and pressing the ">>" button to move them
over to the left. Regardless of whether gap characters are included as valid residues for the
purposes of shading calculations, -', '~ and . characters are always treated as gaps internally.
Also, athough gaps may be included for the purposes of calculations (they may viewed as a
mismatch on the basis that two homol ogous sequences differ at a position where one contains a
base and the other has lost it [or the other is an insertion], gaps are still not shaded as identities,
sincein redlity they are not true physical entities. Keep in mind that al characters are treated
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separately for the handling of valid residues vs non-residue characters, so if al gap characters are
to be recognized (-, ~ and .), they all must be present in both the amino acid and nucleic acid lists
of valid residues.

L ocking a sequenceto prevent accidental edits

A sequence may be locked to prevent the ability to slide residues in that sequence or insert or
type over characters in the sequence either in the alignment window or the single sequence edit
window. If that sequenceis grouped, hand aignment (by sliding only, not right mouse click
addition or deletion of gaps) of that sequence and all other sequencesin the group is aso
blocked if and only if the sequence group has group alignment locked. To lock a sequence, open
the sequence in the single sequence editor by either double-clicking on itstitle or by highlighting

box, then press"Apply and Close".

Anchoring a column to protect aligned regions

It is sometimes useful to be able to lock a column of an alignment without having to
worry about accidentally pushing or pulling sequence over that position, athough it may be off of
the current viewing screen. BioEdit therefore allows the anchoring of as many columns as
necessary to protect regions of an alignment that you don’t want to get messed up. To anchor a
column, depress the add / remove column anchors button (), then click the mouse over the
column you want anchored. To anchor an entire region, add a column anchor to each side of the
region you want protected. If you want to make sure that no alignment is possible in this region,
simply add an anchor to each side, unselect all sequencetitles, select all the residues within the
region (highlight the region with the mouse by dragging the mouse on the ruler bar over the
region, then choose “ Sequence->Gaps->Lock Gaps’ to lock all the gapsin that region. That
region should be effectively locked until the anchors are removed (or the "“ignore anchors’
button is pressed down).

To remove an anchor, depress the ! button, then click over an existing anchor to removeit.

If you want to adjust the alignment in an anchored region, but don’t feel like resetting all of the

anchors, you may depress the “ignore column anchors’ button (@) and make your adjustments.
Be sure to hit the “ignore column anchors’ button again after the adjustments are finished to turn
it off and make the anchors active again.
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Comments

Any sequence may be made into acommment that simply takes up space in the alignment
window but does not participate in shading or calculations and does not count as an actual
sequence. Other than this, acomment is treated internally as just another sequence which is
simply ignored in some situations and isitalicized in the main alignment doc window. Any valid
ASCII characters may be typed in acomment. To create acomment simply create a new
sequence (" Sequence->New Sequence') and, in the single sequence editor, change its "Type" to
"Comment":

[

Unknown
DHa,

FMa,
Mucleic Acid
Frotein

Phylogenetic Tree Viewer

BioEdit version 5.0.6 contains a very rudimentary phylogenetic tree viewer that will open
and view phylip-formatted treefiles. Also, multiple trees may be linked directly to alignment
files (up to 50 trees may be linked to one alignment), and phylogenetic tree information, along
with the current node and branching pattern, is saved in the BioEdit file format. The tree viewer
also allows flipping of nodes (in away that does not alter the phylogeny), saving, printing, label-
editing, and viewing the tree with or without distance information. Only arectangular cladogram
view is currently available, however. For aternative formatting options | recommend using
TreeView, which is available on the WWW from Roderic Page at
http:://taxonomy.zoology.gla.ac.uk/rod/rod.html. Theinstallation for TreeView version 1.5.2 is
distributed with BioEdit, and the TreeView.zip file can be found in the BioEdit installation
folder.

To open aphylip tree in BioEdit, simply choose “File->Open” from anywhere in the program.

BioEdit should automatically figure out that it's atree file and open it appropriately. A sample of
how atree might look in BioEdit is shown on the next page:

46



/“ Phylogenetic Tree: Treefile
Tirmes Mew Foman j I vl B E =
E.coli
P mirabili
H.influenz
BE.aphidico
Pputida
C hurnetti
1 T maritima
—c g Ments
! M prrevinot
M. capricol
— ] H.prlot
B zubtilis
3 PCCAE03
S bikinden
3.coelicol
— Mlluteus
E M.tubercul
M leprae
—¢ T pallichum
B.burgdof
01

Y ou may click the mouse on any node that has a small square (o) at itsjunction to flip the tree
around that node. Thiswill reverse the position of all downstream nodes and leaves (the final
labels at the very end of each branch) while preserving the overall branch pattern and distancesin
thetree.

To edit alabel, click the mouse on the label on the screen. The label will go into edit mode, and
will become completely selected . Y ou may then type the label you wish to rplace it with. When
you are done, either select a different place on the tree window with the mouse, or press enter.
To cancel the editing, press <Esc> (the escape key).

Note: Trees are sometimes written with more than two branches coming off of the same node.
I’ve noticed that trees written by Phylip programs will sometimes have three branches coming
directly off thefirst node. The BioEdit tree viewer allows more than one branch off of each node
(up to 10, actually, just to be safe), but when atree is opened directly in the BioEdit tree viewer
from afile, if the tree has nodes with more than two branches, it is automatically converted to a
completely binary tree by creating an extra node of distance O at each point where there is more
than one branch point from anode. The tree topology does not change, and this allows one to
orient all branch points relative to each other. Upon opening atree, the tree isiterated through,
moving each branch beyond 2 for any node to it’s own, new node (with a distance of 0 from its
parent), until there are no nodes with more than two branches. When atree isimported into a
BioEdit alignment, however, this conversion is not performed, and the tree is imported directly as
itiswritten. Itisviewed inthe same viewer, but the original node organization is retained.
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Y ou may save the tree from the File menu (File->Save). The current version of BioEdit is
limited to opening and saving phylip-formatted trees. In phylip format, the above tree looks
something like this:

(P.mrabil

. 14167, ((((M genitali: 0.24742, M pneunoni: 0.43983): 0.88981, (M capri col
. 70024, (H. pylori: 1.37587,B.subtilis: 0.53651): 0.19415): 0.0886):

. 04525, (S. PCC6803: 0.87437, ((M tubercul: 0.14643, M | eprae: 0.30498):

( i: 0.13368, ((B.aphidico: 0.6262, (((T.maritima:

1

0

0

0.56324, (M | uteus: 0.65897,(S. bikinien: 0.1209,S.coelicol: 0.01772): 0.29437):
0

0

0

0

.14817): 0.59556): 0.14169): 0.18393,(T.pallidum 1.3449, B. burgdorf:
.75431): 0.40702): 0.06668): 0.13184,C burnetti: 0.76309): 0.22955,P. puti da:
.45219): 0.10167): 0.15512,H influenz: 0.24691): 0.08603): O, E. coli

. 12297);

The BioEdit tree viewer supports only onetree at atime, and if atreefileis opened that has
multipletreesin it, only the first tree will be loaded. However, when importing treesinto an
alignment file, al of the trees (up to 50 anyway) will be loaded into the alignment (as separate
tree entries).

The tree viewer formats a tree to the current size of the viewing window, and does not now
support multiple paging, zooming, or manual size specification, so it isonly suitable for rather
small trees. Also, printing is rather primitive, and simply scales to the size of the printer page.
Right now, there is no copying to the clipboard. To produce an image of atree, | recommend
TreeView, which copies trees nicely to the clipboard as a Windows metafile.

Importing Phylogenetic Treesinto an alignment

It is sometimes convenient to have a phylogenetic tree handy showing the relationships
between sequences in an alignment. For this reason, BioEdit 5.0.6 and above alows you to
import one or more phylogenetic trees into an aignment file (as long as they are phylip-
formatted), and to save those trees in a BioEdit-format alignment file. Y ou may have up to 50
treesin onefile. Normally, only one treeis probably desired, but one might have a set of
equivalent trees generated by parsimony methods, or perhaps you want to have trees showing the
relationships between sequences in subgroups of an alignment.

To import atree into a BioEdit alignment, open the alignment (File->Open), then choose
“ Alignment->Phylogenetic Tree->Import Tree”. The menu will look something like this:

Alignment  Wiew  Waorld Wide Web  Accessory Application  BMA - Oplions

Phylogenetic Tree m
i

Mirimize Alignment iew Tree
tinimize alignment to mazk Remove Tree

Semirnea ldenbibo bd Atriv I

Y ou will be prompted to specify the tree file to import. To view the imported tree, choose
“ Alignment->Phylogenetic Tree->View Tree-> (tree number)”. For example, if you have three
trees associated with an alignment, the menu will ook like this:
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Alignment Miew Waorld Wide Web  Accessory Application  BMA  Options  Window

Phylogenetic Tree Import Tree I

Mirimize Alignment Wiew Tree » 1
kinimize alignment to mazk Remove Tree # q
Sequence |dentity b atrix | 3

| [—— bd e Blmrm

Y ou may then save your file in BioEdit format and your associated trees will be saved with the
file. Kegpinmind that, if afileisnot saved, a“Revert to Saved” operation will also remove any
trees that were not saved with thefile.

Y ou may remove atree with the “ Alignment->Phyl ogenetic Tree->Remove Tree” option.

Y ou may aso open atreein the tree viewer and choose to associate it with an open alignment
file, if it is easier to see the treeto make sure it is the correct one. To do this, open the tree from
the File->Open command from anywhere in the program, make sure you have your alignment file
open, then, from the tree viewer, choose “File->Associate Tree With Alignment”. You will get a
dialog that lists al the currently open alignments, from which you can choose the appropriate
alignment.
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Filefor mats

Fileformatsread and written by BioEdit
BioEdit v5.0.0 reads and writes the following formats:

» BioEdit

e Genbank

e Fasta

e NBRF/PIR
 Phylip3.2/2
e Phylip4d

* Inaddition, BioEdit version 4.7.0 and above will read ABI model 377 autosequencer files.
The sequence is extracted and the trace is displayed on the screen and may also be printed in
color. BioEdit version 4.7.7 and above allows editing the editable sequence. The current
version also reads SCF trace files (versions 2 and 3), and ABI 373 and 3700 files.

» BioEdit 4.7.7 and above a so read both Clusta W and GCG-formatted files, but it does not
write them.

In addition to these formats, an external input/output filter (Don Gilbert’s ReadSeq) is provided,
allowing for the import and export of the following formats:

* |G/Stanford

 EMBL

* GCG (single sequence only)
 DNAStrider

* Fitch

*  Zuker (import only)

* Olsen (import only)

* Plain or raw (single sequence only)
 PIR/CODATA

*  MSF (multiple sequence format)
« ASN.1(NCBI)

» PAUP/NEXUS

Documentation for the ReadSeq utility can be found in the file ReadSeq.txt in the /apps folder of
the BioEdit installation directory. Use of this utility within BioEdit is automatic when opening
sequences. If afileisopened which is not one of the formats read by BioEdit, you be prompted
to try to open it with ReadSeq. If ReadSeq can open it, it will be imported into BioEdit as a
GenBank file, otherwise it will be opened astext. To save afilein one of these formats, choose
File->Export->Sequence alignment from an open document.
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BioEdit Project File Format

BioEdit provides a specialized binary alignment format for very fast opening and saving of large
alignment files (20 Mb+ file sizes -- even up to 100 Mb or larger). Reading and figuring out raw
text becomes very slow in large alignments of formats such as GenBank, where thereis no
header telling the program how may sequences there are or how big they are.

The structure of a BioEdit Project fileis asfollows:

* Header

1. offset 0xO0000000: the string “**BioEdit Project File**” identifies the file as a BioEdit
Project file (first version).

2. Thestring “**BioEdit Project File02" at offset 0x00000000 identifies the file as version 2
of the BioEdit format (the current version). Previous versions of BioEdit will not read the
current BioEdit format, but BioEdit v5.0.0 or above will read the old BioEdit format.

3. offset 0x00000018: the number of sequencesin thefile.

4. offset 0x0000001C: the index of the mask sequence (if thereis one).

5. offset 0x00000020: theindex of the numbering mask (if there is one).

» Offset 0xO00000C8: The offsets for each sequence data structure.

Each sequence structure consists of atitle, a sequence, the sequence type, and al of the same
GenBank fields included with a GenBank file in BioEdit. In addition, in BioEdit v5.0.0 or
above, graphical sequence annotations, sequence grouping information, consensus sequence
information, sequence locking status, and positional flags are saved. None of these |atter
additions are saved in any of the other, standard, formats Each field is preceded by along integer
specifying the length of the data, so each piece of data may be read from the file asa single
chunk, which allows afile to be read very quickly.

51



GenBank Format

GenBank files written by BioEdit have the following minimal format:

LOCUS Escheri chi 119 am no aci ds
DEFI NI TI ON  Escheri chi 119 am no aci ds
ORIG N

1 MVKLA FPREL RLLTP SQFTF VFQQP QRAGT PQ TI LGRLN SLGHP RIGLT
51  VAKKN VRRAH ERNRI KRLTR ESFRL RQHEL PAMDF VWVAK KGVAD LDNRA
101 LSEAL EKLWR RHCRL ARGS

/1

LOCUS Pr ot eus_m 119 am no acids
DEFI NI TION Proteus_m 119 am no acids
ORIG N

1 MVKLA FPREL RLLTP KHFNF VFQQP QRASS PEVTI LGRON ELGHP RIGLT
51 | AKKN VKRAH ERNRI KRLAR EYFRL HOQHQL PAMDF WWLVR KGVAE LDNHQ
101 LTEVL GKLWR RHCRL AQKS

/1

efc...
The LOCUS, DEFINITION and ORIGIN keywords are looked for in detecting GenBank files.

GenBank files may also contain additional information. The following fields may be included in
any GenBank sequence entry, and are looked for when opening a GenBank file:

LOCUS: Thelocus of the sequence (often the position in the genome). Thisfield is generally a
single line and contains the Locus name, length of the sequence, and often the date of
submission. Previous versions of BioEdit used the LOCUS as the sequence title.

DEFINITION: A description the sequence, usually one-line. The definition field is used as the
default title in the absence of a BioEdit-specific “TITLE” field.

TITLE: ThisisaBioEdit-specific field and should be ignored by other programs that read
GenBank format. Thetitlefield allows you to save sequencetitlesthat are different from either
the LOCUS or DEFINITION field entries. Thisisincluded so that user-defined titles may be
given to sequences downloaded via Entrez without changing the original datain the sequence
file. The TITLE field isnot a part of a standard GenBank file and is used only by BioEdit. If this
field is a problem with a sequence when trying to open it with another program, open the
sequence as text and delete this field before using the file with the other program.

ACCESSION: the GenBank accession number for the sequence.

PID or NID: Protein or Nucleic Acid ID.

DBSOURCE: The database from which the sequence was obtained.

KEYWORDS
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SOURCE: The source of the sequence (usually the organism from which it was obtained). This
field often contains the subfield ORGANISM, which gives a description of the organism (often
the taxonomic classification).

REFERENCES: references associated with the sequence submission.

COMMENT: miscellaneous information. A convenient place for user-defined information
associated with a given sequence.

FEATURES:. Sequence featuresincluding trandations, promoters, more source information, etc.

ORIGIN: Marks the beginning of the actual sequence data. Two forward slashes (/) designate
the end of the sequence.

The LOCUS, DEFINITION and ORIGIN fields are required for a GenBank file to be recognized
by BioEdit. The other fieldsare optional. When GenBank files are saved, if LOCUS or
DEFINITION fields are empty, they will be created with the sequence title and length. In this
case, the LOCUS and DEFINITION will be identical. Other empty fields are not written into the
sequence entry.

When opening afile, each field isread in asasingle text block. subfields are not formally
recognized, so any “unusual” formatting that may exist in the original file (non-standard spacing,
for example) will be appear asis when afileisopened in BioEdit. When saving a GenBank file,
however, specific subfield names are looked for and spaced asin a NCBI Entrez GenBank or
GenPep report. The following subfields are looked for:

REFERENCES fidd(s):
reference number (format = REFERENCE <num> <description>)
AUTHORS
TITLE
JOURNAL
MEDLINE
REMARK
STRAIN

FEATURESfield:
Previous versions of BioEdit only looked for a small selection of GenBank FEATURES tags.
Version 5.0.0 or above looks for al of the following 67 tags:

3clip
3UTR
5'clip
5UTR
-10_signdl
-35_signdl
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alele
attenuator
CDS
C_region
CAAT signal
conflict
D-loop
D_segment
enhancer
exon
Gene
iDNA
intron
J_segment
LTR
mat_peptide
misc_binding
misc_difference
misc_feature
misc_recomb
misc_RNA
misc_signal
misc_structure
modified base
MRNA
mutation
N_region
old_sequence
polyA_signal
polyA_site
precursor_RNA
prim_transcript
primer_bind
promoter
Protein
protein_bind
RBS
Region
repeat_region
repeat_unit
rep_origin
rRNA
S region
satellite
scRNA
SecStr
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sig_peptide
Site

snRNA
source
stem_loop
STS
TATA_signd
terminator
transit_peptide
tRNA

unsure
V_region
V_segment
variation

Any dataincluded within afield will be saved, however, in REFERENCE and FEATURES
fields, data saved under a subheading not shown above may not be spaced as expected.

To edit specific fields, see Editing in an Edit Box
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Fasta Format

Fasta/Pearson files written by BioEdit have the following format:

>Escherichi 119 am no acids
MVKLAFPRELRLLTPSQFTFVFQQPQRAGTPQ Tl LGRLNSLGHPRI GLT
VAKKNVRRAHERNRI KRL TRESFRL RQHEL PANDFVVWAKKGVADL DNRA
L SEAL EKLWRRHCRLARGS

>Proteus_m 119 am no acids
MVKLAFPREL RLL TPKHFNFVFQQPQRASSPEVT! LGRONELGHPRI GLT
| AKKNVKRAHERNRI KRLAREYFRL HOHQL PANDFVVLVRKGVAEL DNHQ
LTEVLGKLWRRHCRLAQKS

etc ...

The“>" character followed by a string consistent with atitle, followed by an unbroken string of

charactersislooked for in detecting Fastafiles.
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NBRF/PIR format

NBRF/PIR files written by BioEdit have the following format:

>P1; Escheri chi
Escherichi 119 am no aci ds

MVKLAFPREL RLLTPSQFTF VFQQPQRAGT PQ TILGRLN SLGHPRI GLT
VAKKNVRRAH ERNRI KRLTR ESFRLRQHEL PAMDFVWAK KGVADLDNRA
LSEALEKLWR RHCRLARGS*

>P1; Prot eus_m

Proteus_m 119 ami no acids

MVKLAFPREL RLLTPKHFNF VFQQPQRASS PEVTI LGRON ELGHPRI GLT
| AKKNVKRAH ERNRI KRLAR EYFRLHOHQL PAMDFVVLVR KGVAELDNHQ
LTEVLGKLWR RHCRLAQKS*

etc ...

>P1,; signifies a protein sequence, >DL; would signify a nucleic acid sequence.
The sequence is written in blocks of 10. The end of a sequence is denoted with an asterisk.
NBREF files are detected by the presence of “>P1;” or “>DL;” immediately followed by atitle
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Phylip 3.2/2 format

Phylip 3.2/ Phylip 2 files written by BioEdit have the following format:

3 136 |
Escheri chi MVKLAFPREL
VAKKNVRRAH
LSEALEKLWR
Pr ot eus_mi MVKLAFPREL
I AKKNVKRAH
LTEVLGKLWR
Haenophi | u M_KWWKVYLH

TI LARKNNLE
DFVFVAKNG

All sequencesin Phylip format have the same length. Thefirst line of the file specifies the

RLLTPSQFTF VFQQPQRAGT
ERNRI KRLTR ESFRLRQHEL
RHCRLARGS- - ---------
RLLTPKHFNF VFQQPQRASS
ERNRI KRLAR EYFRLHQHQL
RHCRLAQKS- - ---------
NHNSQFLVWK LNFSRELRLL
HPRLGLTVAK KHLKRAHERN
GKLDNNTFAQ | LEKLWORHI

PQ TI LGRLN SLGHPRI GLT
PAVDFVVVAK KGVADL DNRA
PEVTI LGRN ELGHPRI GLT
PAMDFWLVR KGVAELDNHQ
TPl QFKNVFE QPFRASTPEI
RI KRLVRESF RLSQHRLPAY
RLAQKS

number of sequences and the length of each sequence. The“1” here specifiesthat it is Phylip 3.2
format rather than Phylip 4. Each sequence iswritten after itstitle in blocks of 10. Thetitlesare
10 characters long and the sequences are spaced three spaces after the titles.
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Phylip 4 format

Phylip 4 files written by BioEdit have the following format

3 136
Escheri chi MVKLAFPREL
Pr ot eus_m MVKLAFPREL
Haenophi |l u M_KVVKVYLH

VAKKNVRRAH
I AKKNVKRAH
TI LARKNNLE

LSEALEKLWR
LTEVLGKLWR
DFVFVAKNG

RLLTPSQFTF VFQQPQRAGT PQ TI LGRLN SLGHPRI GLT
RLLTPKHFNF VFQQPQRASS PEVTI LGRQN ELGHPRI GLT
NHNSQFLVWK LNFSRELRLL TPI QFKNVFE QPFRASTPEI

ERNRI KRLTR ESFRLRQHEL PANMDFVVWWAK KGVADLDNRA

ERNRI KRLAR EYFRLHQHQL PAMDFVVLVR KGVAELDNHQ
HPRLALTVAK KHLKRAHERN RI KRLVRESF RLSQHRLPAY

GKLDNNTFAQ | LEKLWORHI RLAQKS

The sequences are al the same length and are interleaved. The first line specifies the number of

sequences and the length of the sequences. The sequences are written in blocks of 10 and

interleaved with 50 residues of each sequence written per block. The titles are written before the

first block. Titlesare 10 characters long and sequences are spaced 3 spaces after the titles. All

blocks are spaced over to the right 13 spaces.
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ABI Autosequencer TraceFiles

BioEdit version 4.7.0 and above will read ABI model 377 tracefiles. | am not yet familiar with
older ABI filesor .SCF files, so thereis currently no support for these files. Much of the
information needed to decipher ABI files was obtained from the ABIView web page (author
David H. Klatte). Information for printout headers was figured out using a hex editor and the
information from David Klatte as a starting point.

To open an ABI trace file, simply open the file asif you are opening any other file in BioEdit. As
with alignment and plasmid files, the file format will be automatically detected (you may use the
*.abi filter if the file(s) is/are named with a.abi extension). When an ABI fileis opened, the
(editable) sequence will be extracted into a new sequence/alignment document and the trace will
be displayed in a separate window. An ABI file contains a duplicate sequence that alows both
editing of the sequence and preservation of the original base-calls The non-editable sequenceis
displayed in the trace window upon first opening atrace. The following example shows the
sample.abi file that comes with the BioEdit installation opened with the windows tiled:

:;Eifi-‘Bqudit Sequence Alignment Editor
File Edit Sequence Alignment Miew ‘world'wide Web Accessory Application BMA - Options  Window  Help

= O

%* ABI Chiomatogram: C:\BioEditDev\Sample. abi R e -0l x|

s Selected: none | Sample: PETES8/PETFOR |File: C:BicEditDeviSample. ohi

50 a1} 70 30 o0 100
TOGTTTAAC TTTAAGAAGGAGA TATAC CATOOGCCATCATCATCATCATCATCATCAT CAT CACA

" DMA sequence from C:\BioEditDev\Sample.abi

- b 1. Examiner: X:I
=] - vI
= ICDu”E' New JITI B [T Mask nmbrs. ¥~ Calculate |

Miode: ide Selection; 0 Sequence Mazk: None Start
oee ISBIECt / Slide J Puozitian: Murmbering tazk: MNone tuler at: 1
— — mE: = THEE rrac = GAT GAT TT6c Scrall Ej j’
g I b1 D % &M | |- E ﬁ%ﬂﬁillclc!llc.ﬂc“ Ll @MIEspeedslowq,qfast
[ ;I""I""IFFFT'TTTT'TTTT|T"'I""I"'F|FFTT'TTTT'TTTTI""I""I"FF'TT"
| a0 &0 70 g0 20 100 110 4

PETAEE,/PETFC|TETTTAACTT TAAGAAGGAGATATACCATGEGCCATCATCATCATCATCATCATCATCATCACAGCAGCGGECC

SN ] Ll 2l

-

The mouse may be used to select any part of the trace and partial sequence may be copied from
the trace window. Alternatively, the entire sequence may be copied or exported as raw text or
Fasta.
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Vertical scaling resizes proportionately when the window isresized. The entire trace may be
zoomed via the Zoom menu, and horizontal scaling may be changed separately from the
Horizontal Scale menu.

To edit the sequence, you must first switch to the editable sequence by choosing View->Editable
sequence. Individual basecalls may be edited by highlighting the base with the mouse and typing
over it. Saving the edited sequence will not alter the non-editable sequence, and the non-editable
sequence may be viewed at any time by choosing View->Non-editable sequence. The non-
editable sequence is always shown by default upon first opening an ABI file. The editable
sequence, however, is the one extracted to a sequence document. The edited sequence may be
reverted at any time by choosing Edit->Revert edited to non-editable sequence.

Y ou can view some of the relevant header information from the file by choosing File->info.
The trace and sequence may be reverse-complemented by choosing View->Reverse complement.

A printout of the trace looks similar to an ABI Prism printout. For most purposes, smply
choosing “Print” from the “File” menu will produce aformatted print of desirable scaling.
However horizontal and vertical scaling may be changed for printing viathe “Print Scaling”
menu under the “File” menu. A set of presets may be chosen, or any exact scaling may be
specified (as %) by choosing “other”.

The picture on the following page is similar to what can be expected for page one of a printout of

the sample.abi file. A normal printout, however, will print at the ouput resolution of the printer
(the image in this document is a bitmap).
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Model 377 File: Sample.aki Signal G:90 A80 T:61 <83 Fage 1 of 2
b ABlZ200 Torm Hall DT{BD Set Any-Frimer} ar2rnasg
BIO Wersion 3.2 FPETESB/FETFOR dR Walt Matrix File Spacing: 11.6000003814697
._.mh,nm Lane 34 Foints 1091 to 9144

Bio Edit wersion 4.7.1

TIEAEATCCCTH AL CATANCFAT TC CICT TAGAAATAAT TT TG TTAA CTTTAAGA A CAGATATAC CATGEGUCATCAT CAT CAT CAT CATCATCAT CAT CACAGCAGUGGC
1] 1] 1] 40 =11] 1] el | 1] L] 100 110

|EATHT CEAABE T CG TEAT AT GC TCGABT TEAT TC € CCAAAGE AT TC T GAT GAAA TTCTTT GAC TTC CAC ATACAGGGCAGCGAC CATGAT TC CAGE CTRAGACTE CT
1H 130 140 150 160 170 180 120 il ] i TH

CLTTEAGG CATCACGT CT CGGE TAT CAGGGL GEAGT TCTHEETATAC CCTTETGAGAGATACC CTGAC CTCAAATCAGAL CTTGAAT CC LT CAGGGAGAALL C
3 140 150 10l 7o 80 ] 300 I FH

TEAALTCCAGGALT TTGAGATAG CCAGGGETETAATCGATAAATGCAT CTGAC C O CETEATATGAGGAG AT CCGTEAATAAATT CAGE AALAAGELT &
I3 340 350 360 370 0 E ] 400 410 4H

|6E AL COTGE CA TCAAC CATET T € TCE CAAGGEANGCT GOAAGAAA CAAT BT CEECTTGTTG AAC TCCCCOLT GEUG GA U6 TEAT CBRIET € CTEE CT CAANGTACCG
530 540 550 560 570 580 00 [ 1111] 610 (1]
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Saving sequence annotation information
BioEdit will save much of the information contained within a standard GenBank formatted file.
The following fields may be included in any GenBank or BioEdit file:

LOCUS
DEFINITION
TITLE (BioEdit specific -- not standard in GenBank format)
ACCESSION
PID or NID
DBSOURCE
KEYWORDS
SOURCE
REFERENCES
COMMENT
FEATURES
In addition to the text information retained in the "FEATURES" field, sequences may be
graphically annotated independently of these GenBank fields either manually or automatically
using the standard tags from the GenBank FEATURES field. Graphical annotation information,
however, will only be saved in BioEdit file format.

For a description of the above fields, see "GenBank file format".
For a description of the graphical sequence annotations, see "Graphical Feature Annotations”.
Note that information other than sequence, title and length will only be saved in GenBank and

BioEdit format. It may be easiest to keep most sequence filesin GenBank format and only use
other formats when a specific conversion is needed.

Reading Files saved with BioEdit with a Macintosh program

Macintosh computers use a different carriage return character than PC-compatibles. If you need
to use afile created in BioEdit with a Macintosh program such as SegApp or DNA Strider, you
may need to first open the file with aword processor such as Microsoft Word or WordPerfect,
then save it again to produce the correct carriage returns. BioEdit will correctly read afile that
was created on a Macintosh or a UNIX machine.
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Toggling between nucleotide and protein views

To control the way trandlation handles gaps , make sure the “Toggle Translation Control” option
is checked from the “View” menu, and that the “Force contiguous codons’ and “Ignore gaps that
split codons’ checkboxes are visible on the control bar of an alignment document.

When working with nucleotide sequences that code for proteins, BioEdit allows the toggling

back and forth between nucleotide and protein sequences, with each view reflecting any gaps
inserted or deleted in either view. The nucleotide information is retained when toggling back
from aprotein view (it is not re-translated degenerately).

To switch back and forth between nucleotide and protein views of protein-encoding nucleic
acids, first trim the 5’ end of the sequence(s) to the start codon and make sure the coding region
isinframe 1. Then either select the sequences to toggle and choose “ Toggle Trandation” from
the Sequence” menu, or choose “ Toggle Trandation” from the “ Alignment” menu (in which case
all sequences will be automatically selected and toggled). The sequences may be aigned in
either view. Additiondly, if the protein view is Clustal-aligned, the underlying nucleotide
sequences will be updated with the proper gaps.

Note 1: When saving an alignment, if the sequences are toggled on the protein view, the
nucleotide sequences, not the proteins, are saved.

Note 2: Thisfeatureisonly functional when the starting sequences are nucleic acid. If the
starting sequences are protein, then this feature does not do anything when chosen, because the
coding region of a protein cannot be known by examining the amino acid sequence alone. The
feature can be used on degenerate reverse trandations by first reverse-trandating the sequences,
then choosing this menu option.

Note 3: There are three available modes for handling gaps placed in nucleotide sequences
which either split codonsinternally or occur assinglesor pairs. A gap in aprotein sequence
will correspond to three gaps in the encoding nucleotide sequence. However, if aone or two
gaps are placed in a nucleotide sequence, or gaps are placed directly within a codon (in frame 1),
thereisaproblem. BioEdit handlesthisin one of three ways, depending upon the options
chosen:

To alter the options for trand ation toggling, the “ Trandlation Toggle Control” option under the
“View” menu must be checked. When this menu item is checked, there will be two checkboxes
on the right side of the top panel of the alignment window. The available options are:

1. Forceall gapsto occur in groups of three and to only occur between codon (not within
codons). Inthismode, if agap isintroduced inside a codon, the nucleotides downstream are
shifted left until afull codon is produced. If thisresultsin asingle or double gap (or if oneis
manually put between two codons), the gap is extended to three places to make a single amino
acid sizegap. Thiswill cause gap positions to automatically change if they are not introduced as
triplets between codons. It iseasiest to smply align the sequences by their protein trandations.
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** This mode is active when the * Force contiguous codons’ checkbox is checked.

2. Ignore gaps that split codons. In this mode, rather than trying to “fix” the sequences, any gaps
that occur within codons or occur don’t make awhole amino acid gap are simply ignored in the
protein trandation. They are still retained in the nucleotide sequence, however, and will still be
there when the proteins are toggled back to the nucleotides.

** This mode is active when the “Ignore gaps that split codons’ checkbox is checked
Mode 1 and 2 cannot be active at the same time.

3. Neither mode. Thisis active when neither checkbox is checked. In this mode, no attempt to
fix sequence editsis made, but gaps are not ignored in translating. Any gap that is not amultiple
of three will cause aframeshift. A gap that occurs within acodon (in frame 1) will cause the
trandlation to see an “X” rather than avalid amino acid.

** This mode is active when neither of the above checkboxes is checked.

Printing

To print an alignment, choose “Print Alignment as Text” from the “File” menu. A preview
window will appear. This preview isincorporated into arich text editor, and you may edit the
alignment on-screen if you wish. If atitleis specified, it is printed at the beginning of the
alignment. Pressing the preview button causes the alignment to be re-drawn in the preview
window with the selected specifications. If any on-screen editing will be done, make sure that
the basic format (residues per line, characters per title, etc) is set, because pressing preview again
will overwrite any typing in the preview window.

The preview interface isfairly straightforward:

" Print Preview: C:ABioEditDev\Bacterial RNazeP_proteins_gb

File Edt Fomat Help

| é1 %l %l&ﬁ IEaurierNew j I'IEI ﬁ Preview | Print I Close | Cancel |
Residues per row |50 =1V Titlesonleft ¥ Titles Bold r Sequences Bold Page setup -- Margins:

p- _ ™ Tifles onRight [~ Tilles Italicized T Sequences Italicized e _?I = e
Characters in tiles {10 TIW ShowFuler [ Tiles Underined T Ruler Bold_ ap = 025 ?n. ? :_Il 0.25 ?n_
Title: |.-’-'«Iignment: C:\BioEditDevhBactenal RMaseP_proteins. gb Riuler in italics Bottom L= 025 i H'ght_vl 025 in.

Note: The preview window will do its best to show a preview that will let you know if you’'ve
overshot on residues per row with the currently chosen right margin and font size. If this
happens, the individual lines of sequence will wrap. Thisiswhat will happen on the printer if
you try to print with the residues per row set beyond the end of the specified right margin. If this
happens, decrease the residues per row, font size, or the right margin, or print in landscape
orientation.
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Exporting asraw text

BioEdit provides an easy function for converting alignments into properly spaced raw text files.
To export the alignment as araw text file (no formatting), select the “ Save As ...” option from the
“File” menu and choose “ Text Files’ from the  Save astype” optionsin the save dialog. You
will get adialog that asks for the number of residues per line (by tens) and the number of
characters per title to save:

Exporting asRich Text

An alignment shaded for identities and similarities may be exported in rich text format,
preserving the residue highlighting as long as the file is viewed with Word 97 or newer or
another word processor that supports highlighting in rich text. The aignment is shaded
according to the current settings for shaded graphic views, and exporting in this format may also
be done directly from the shaded graphic view form. To export an alignment as rich text directly
from a document, choose File->Export->Rich text with current shaded view settings.

Shaded graphic view of alignment

For a presentation of the alignment showing identities and similarities shaded, select the titles
for the sequences you want to include, then choose “Graphic View” from the “File’ menu of an
open document. Thisissimilar to the print preview, but allows for the shading of identical and
similar residues in the alignment, and allows you to show any subset of the alignment.

The following options are currently offered:

» Variable threshold percentage for shading residues (one threshold for both identities and
similarities)

* Show or hideruler

» Show or hidetitles on the left and right of sequence data

»  Show or hide position numbers on the left and right

» Variable number of residues per line (by tens -- 20 to 2000)

» Variable number of characters per title (5 to 30)

» Titlesmay be bolded, italicized and/or underlined

*  Sequences may be italicized and/or bolded

» A choice of scoring matricesis available

* Fonts: Any font can be used and will spaced approximately correctly. However, some fonts
look odd in thisview (most, actually, are spaced too wide because the widest character must
be accommodated), and typeset fonts work best. For greater control over the font, choose

“Character Font” from the “Font” menu.

» Colorsfor background of page, identities and similarities and colors for non-identical,
identical and similar residue characters.
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» A title may be added which will be placed at the beginning of each page. Inthisrelease, this
creates aproblem if the alignment requires more than one page, so it is best to leave the title
field blank.

» Alignment may be drawn in the standard color table colors (to alow printing of the alignment
in color).

» Shading according to identity and similarity (threshold defined by “ Threshold (%) for
shading” on control panel) may be done with the user defined colors on the control panel, or
with current alignment color table colors.

» Linesof sequence may be blocked into groups of 10 (like a Phylip file) or printed as
continuous, unbroken lines.

» Trangdations may be shown below nucleic acid sequencesin either 3-letter or one-letter codes

» Shaded alignments may be exported as rich text documents which preserve colored
highlighting (Word 97 or above, or equivalent, is required to display highlighting in rich
text).

When certain changes are made to the current view, the “Redraw” button must be pressed for the
changes to take place on the screen. Many changes are automatically updated.

To change colors, either double-click on the labeled, colored box, or press the small button to the
left of it.

To copy apage to the clipboard for pasting into another application, choose “Copy” form the
“Edit” menu. A page may be copied as a bitmap or an Enhanced Windows Metafile (EMF).
Copying as ametafile allows for pasting directly into an application such as PowerPoint for
inclusion of a shaded alignment in a slide presentation, or into a page layout program for creation
of apublication figure. A metafile offers the advantage of being a vectored graphic (the graphics
are defined by formula/code rather than pixels such as in a bitmap) which can take advantage of
the full resolution of the output device. At thistime, only an entire page can be copied. A later
version may offer annotation and selection capabilities, if there is demand for this.

Multiple pages are supported for long alignments, however, this is a serious problem with this
version of BioEdit. Currently, a pageis defined vertically by the page height in inches specified
by the user in the graphic view window. When vertically scrolling through the graphic view, the
current page is shown in the upper right of the form. When the end of one page is reached, the
next pageisdrawninitsplace. Thereis no continuing view from page to page, which can make
viewing page transitions on-screen very tedious. Also, someimage-editing isrequired to
produce an image figure of an alignment that takes more than one page. Currently, it is easiest if
the alignment can be made to fit on one page. The height of a page can be set to up to 100
inches, but thiswill take an enormous amount of memory and is not recommended (each pageis
a bitmapped image). To create an image longer than a piece of paper, you can increase the page
height and copy the image to the clipboard. On a slow computer, thereis adelay as each new
pageisdrawn.

Previous versions of BioEdit determined the page size only vertically. The current version
calcul ates the specified page settings (from the print setup and the margin and page size settings)
and will clip the graphical image if it runs over the right side of the page. This should
correspond rather closely (may not always be perfect) with what will print on the currently
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chosen printer with the current settings. Also, margins are now shown in the graphic view to

reflect afairly accurate print preview for each page.

The following are two shaded views of a ClustalW alignment of bacteriorhodopsin protein

sequences from representative halophilic Archaea:

BioEdit 5equence Alignment Editor - [Graphic Pnnt: C:ABioEditDev\bacteno.bio]
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“BioEdit Sequence Alignment Editor - [Graphic Print: C:ABioEditDev\bacterio.bio]
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I nfor mation-based shading in the alignment window

The following view shows an information-based shaded view of an alignment of 75 16S rRNA
sequences from methanogenic Archaea. The region shown was picked by an
entropy/information-based search for conserved regions.

Compare this view to the split-window view below it showing the same alignment with this
region compared to aless well-conserved region (on the next page).
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Restriction M aps

BioEdit offers two ways to generate restriction maps of nucleic acid sequences. An internal
restriction map utility allows generation of maps for sequences up to 65,536 nucleotides. It has
only really been tested up to about 35 Kb, and it takes awhile on a slower computer for alarge
sequence. You can aso link directly to WebCutter restriction mapping via the World Wide Web.

WebCutter: Highlight the title of the sequence you wish to map and choose “ Auto-fed
WebCutter Restriction Mapping” from the “World Wide Web” menu.

BioEdit: Highlight the title of the sequence you wish to map and choose “ Restriction Map” from
the “ Sequence” menu. An interface window will appear with the following options:

-- Display Map: Display or omit afull map of the sequence and the complementary strand
showing the cut positions of each enzyme. Default: yes

-- Alphabetical by name: Display alist of all enzymes that cut, their recognition sequences,
frequency of cutting, and all positions (5' end starting at 1). Default: yes

-- Numeric by position: A list of all positions that are cut, in increasing order, and the enzymes
that cut there. Enzyme cut positions are defined at the cut site, rather than the start of the
recognition sequence (e.g.. if aBamHI site (G'GATC_C) started at position 1476, the cut
position would be reported as 1477 -- where it actually cuts). Default: no

-- List of unique sites: List of enzymes that cut only once in the entire sequence. Default: no

-- Enzymes that cut five or fewer times. Default: yes

-- Summary table of frequencies: A table of all enzymes currently selected and the number of
times they cut in the sequence. Default: no

-- Enzymes that do not cut. Default: yes

-- 4-base cutters: Y ou may choose to omit enzymes that cut at a 4-base recognition sequence. To
include these enzymes, the box must be checked. Default: no (don’t include 4-base cutters).

-- 5-base cutters: Same as 4-base cutters.

-- Enzymes with degenerate recognition sequences. Many restriction enzymes recognize
sequences loosely. For example, Accl recognizes the sequence “GT'mk_AC”, where‘m’ can be
AorCand‘k canbeGor T. You may wish to exclude these on occasion. Default: include
these.

-- Large recognition sites: Often for cloning, only the common 6-base recognizing enzymes are
used. If you do not want a map cluttered with extra information, uncheck this box (aswell as 4-
base and 5-base cutters).

-- All Isoschizomers: The enzyme list file used is the GCG-format file available from ReBase.
Several enzymes are in this file which cut the same recognition sequence of other enzymesin the
file. To show only one enzyme for a particular recognition site, uncheck this box
(Default=unchecked). If thisoption is chosen, the map will be very large. Isoschizomersfor all
enzymes which you choose to include may be examined by viewing the enzyme table from the
mapping interface (press the “View Current Enzyme Table” button).

-- Three frame translation: Shows a translation along the sequence as shown in the alignment
(assumed to bein the 5' to 3' orientation left to right).

-- Trandation of complement: A three-frame transation of the complementary strand running the
opposite direction.
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Considerations for BioEdit restriction mapper.
-- Numbering is at the nucleotide where the enzyme cuts, not the start of the recognition

sequence. Thisisimportant to keep in mind for enzymes such as Acelll, which recognizes the

sequence “ CAGCTCnnnnnnn'nnnn_". Acelll actually cuts 12 bps. downstream of its recognition
sequence start.

-- The interface window is not an MDI child and is designed to stay on top of the application.

When arestriction map is generated, the window disappears, but the selected options remain as

the default until the application is closed and reopened. To view the enzyme list, the interface

window must either be closed or minimized to see the table list behind it.
-- A different enzyme file may be supplied to BioEdit, but it must be in the GCG format, must be
named “enzyme.tab” (case sensitive), and must be located in the \tables\ folder.

An example of the GCG format for restriction enzyme tablesis:

REBASE versi on 811

gcgenz. 811

REBASE, The Restriction Enzynme Database

Copyright (c)

Ri ch Ro

REBASE codes for commerci al

http://ww. neb. com r ebase
Dr. Richard J. Roberts, 1998. Al rights reserved.

berts

Cct 28 98

sources of restriction enzynes & nethyl ases

A Anersham Li fe Sci ences-USB (4/97)

B Li fe Technol ogies Inc. (1/98)

C M not ech Mol ecul ar Bi ol ogy Products (1/98)

D Angewandt e Gent echnol ogi e Systenme (10/97)

E Strat agene (1/98)

F Fermentas AB (5/98)

G Appl i gene Oncor (10/97)

H Anerican Allied Biochemcal, Inc. (10/98)

| Si bEnzyne Ltd. (10/98)

J N ppon Gene Co., Ltd. (10/97)

K Takara Shuzo Co. Ltd. (1/98)

L Kramel Biotech (7/98)

M Boehri nger - Mannhei m (10/ 97)

N New Engl and Bi oLabs (8/98)

(0] Toyobo Bi ochem cals (1/98)

P Pharmaci a Bi otech Inc. (8/97)

Q CH MERx (10/97)

R Promega Corporation (10/98)

S Si gma (7/98)

T Advanced Bi ot echnol ogi es Ltd. (3/98)
Aar | 3 CACCTGC 0°?! > 1667
; Aat | 3 AGG CCT 0 ! Ecol47l, Pme55l, Stul, SseBl >0 6643
Aat || 5 G ACGT' C -4 >ADEFKLMNOPR 6643
; Aaul 1 T GTAC_A 4 1 Bspl4071,Bsrd, SspBI >| 6251
Accl 2 GI' nk_AC 21 Fbll >ABDEGJI KL MNOPQRS
; Accl | 2 CG CG 0! BstU, Mnl, Thal, Bsh1236l >AJKQ 3992, 7430
; Accl 1] 1 T CCGG A 4 ! BseAl,BsiM, Bspl3l, BspEl, Kpn2l, Mol >EJKQR 3994, 5140

and on like this -- the file sinply ends after the |ast enzyne.
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Restriction Enzyme Browser

When running a restriction map on anucleic acid sequence, it may be useful to show enzymes
available from a particular company. For example, many scientific departments have a contract
deal with companies such as Promega or Boehringer-Mannheim with an on-site freezer from
which enzymes and reagents may be obtained with no delay.

Restriction enzymes may be browsed by manufacturer by choosing a manufacturer and pressing

theil button on the restriction map dialog. Y ou may also examine restriction enzymes at any
time by choosing “View Restriction Enzymes by Manufacturer” from the “Options” menu.

The following dialog will appear:

:j:"Enzymes by Company:
Enzyme:
Haell 2] eutsiter |5_cTac'c
Hincll
Hirdlll |znzchizomers
Hinfl AecgSI, Asp7181
Hpal
kAlul (Other companies that camy Kpnl:
knll Amersham Life Sciences-JSE [4/9) a
b= pl Life Technologies Inc. [1/38]
bAunl Minotech Maolecular Biology Produc
Mar] Angewandte Gentechnologie Syste
) Fermentaz AR [5/98]
Mcil Appligene Oncor [10/97)
Mol Armerican Allied Biochemical, lne. [1
Mlel SibE mzyrme Ltd. [10/98)
MRl x| |NipponGene Ca. Ltd (10/97) |
Current b anufacturer: IStratagene [1498] j
Cloze |

In this example, all restriction enzymes available from Stratagene are listed on the left and Kpnl
is highlighted. The recognition sequence for Kpnl is shown on top, isoschizomers are shown
below that, and other companies are shown which also carry Kpnl. The numbersin parentheses
next to each company name specify the month and year in which the information for that
company was last updated. BioEdit uses the gcgenz table supplied by ReBase, the restriction
enzyme database on the World Wide Web: ht t p: / / www. neb. cont r ebase/

This table may be updated by downloading the most recent version of the gcgenz.* table from
rebase, naming it “enzyme.tab”, and replacing the old table file in the “tables” directory of the
BioEdit installation folder.

Note: The table must be in the gcgenz format. Y ou may open the “ enzyme.tab” file from the
tables folder to see what the format |ooks like, or see Restriction Maps. The restriction enzyme
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table file must be named “enzyme.tab” and must be located in the “tables’ folder in order to be
recognized by BioEdit.

Codon Tables

BioEdit uses only codon tables with the format produced by the GCG program
CodonFrequency. The default codon table that comes with BioEdit isthe E. coli codon usage
table produced by J. Michael Cherry (cherry@frodo.mgh.harvard.edu). The default codon table
is shown below as an example of the format:

Escherichia coli
681 genes found in GenBank 63.

Produced by J. Mchael Cherry (cherry@rodo. ngh. harvard. edu) with the
GCG program CodonFr equency.

Dupl i cates, pseudogenes, nutant and synthetic genes were not included.
Codi ng regi ons were specified using the Feature Table of each entry, then
checked for accuracy. If nore than one stop codon was found the sequence
was not incl uded.

This table was taken directly fromthe SeqPup distribution (Don Glbert).
The following note is left in:

Note for SeqPup usage ----

The start codon needs to be in >>l ower case<< to
be recogni zed by SeqPup as the start codon. O herw se,
Met/atg will be used as the start codon for ORF searching.

Bi oEdit v1.0 al pha has no ORF-searching, but later versions will, and the
sane convention will be foll owed.

AmAci d Codon Nunber /1000 Fraction
Ay GG 1743. 00 9.38 0.13
Ay G 1290. 00 6. 94 0. 09
Ay GGT 5243. 00 28. 22 0.38
Ay GaC 5588. 00 30. 08 0. 40
GQu GAG 3527.00 18. 98 0. 30
Gu GAA 8101. 00 43.61 0.70
Asp GAT 6103. 00 32.85 0.59
Asp GAC 4244, 00 22.84 0.41
Val GIG 4429. 00 23.84 0.34
Val GTA 2231.00 12.01 0.17
Val GIT 3744. 00 20. 15 0.29
Val GIC 2601. 00 14. 00 0. 20
Al a GCG 5946. 00 32.01 0.34
Al a GCA 3899. 00 20. 99 0.22
Al a GCT 3266. 00 17.58 0.19
Al a GCC 4274. 00 23.01 0. 25
Arg AGG 286. 00 1.54 0.03
Arg AGA 464. 00 2.50 0. 04
Ser AGT 1366. 00 7.35 0.13
Ser AGC 2871. 00 15. 45 0.27
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End

atg

2238.
7102.
3047.
4755.

4756.

738.
4970.
4955.

2375.
1263.
2160.
4437.

2504.

887.
1173.

52.
371.
3017.
2629.

2046.
1879.
3443.
3328.

1434.
1274.
1992.
1794.

851.
580.
4534,
4006.

5389.
2375.
2145.
1987.

9749.

565.
1857.
1764.

4371.
1559.
1248.

785.

cooo

Cooo ocoor

COOO ©CO0OO0 0000 0000 OOO0O 0000 0000 00Ok
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Six-frametrandation

A DNA sequence may be trandated in al six reading frames into all possible open reading
frames (simple codon stretches, actually) by highlighting the sequence title in the document
window and choosing either “ Sorted Six-Frame Trandation” or “Unsorted Six-Frame
Trandation” from the “ Sequence” menu. Y ou will get adialog asking you to specify the
minimum ORF size, maximum ORF size, and start codon.

Minimum ORF size: Only codon stretches equal to or greater in length than the minimum will
be reported.

Maximum ORF size: Only codon stretches equal to or lesser in length than the maximum will be
reported. Leave thisentry blank to allow unlimited ORF size.

Start codon: Choose ATG or Any from the drop-down box, or type in any three-base codon you
wish. Only codon stretches beginning with this start codon will be reported. If “Any” is chosen,
codon stretches will basically go from stop to stop.

Differences between sorted and unsorted trand ations:

Sorted: ORFswill be reported in order of start position. Negative-frame sequences are sorted
according to their end positions (first position along the positive sequence). The number of
sequences which can be trandlated and sorted is limited to something above 10,500 sequences.
The exact number, | am not sure of. If a sorted tranglation becomes too large, resources for
storing the sequences to be sorted runs out. If this happens, BioEdit will tell you, then present
the sequences it was able to trandlate. Multiple sequences may be trandated into a single ORF
list suitable for BLAST database creation.

Unsorted: Sequences are reported in the order that their stop codons are encountered in a once-
through, 6-frame simultaneous pass through the entire sequence. The codon stretches are written
into afile as they are encountered and therefore do not need to be stored in memory. Very long
lists can thus be generated. Currently, only one sequence at atime may be translated this way.

No sophisticated ORF identification is currently implemented. sequences are simply translated
into raw codon stretches. A future addition may allow the user to require threshold matches to
consensus promoters and/or ribosome-binding sites for ORF reporting.

Possible open reading frames are reported as shown in the following example:

>ecoli.nb2: 620 to 111: Frane -2 170 aa
STKVFNCASGNPGMAASPVKSSAKI RSASLI LGKASWPLMVESI | ATRW.VI L
AGAERTVATCPCLALLSRI SATRRKRSAFATDVPPNFNTRWVTSLPLVEKKSP
HCQVRAFFCVSCTRQPAPL PWMWMNVVMVLMRFVDWYSVI FI CLCAMPI LV
KVFSDLSQ

>ecoli.nb2: 292 to 2796: Franme 1 835 aa
QCGELFFSTKGNEVTTMRVLKFGGTSVANAERFLRVADI LESNARQGQVATVLSA
PAKI TNHLVAM EKTI SGQDALPNI SDAERI FAELL TGLAAAQPGFPLAQLKTF
VDQEFAQ KHVLHG SLLGQCPDSI NAALI CRGEKMSI Al MAGVLEARGHNVTV
| DPVEKLLAVGHYLESTVDI AESTRRI AASRI PADHWL MAGFTAGNEKGEL W
L GRNGSDYSAAVL AACL RADCCEI WIDVDGVYTCDPRQVPDARL LKSMSYQEAM
ELSYFGAKVLHPRTI TPl AQFQ PCLI KNTGNPQAPGTL| GASRDEDEL PVKGE
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SNL NNMAMFSVSGPGVKGWGVAARVFAAMSRARI SVWLI TQSSSEYSI SFCVP
QSDCVRAERAMQEEFYLELKEGLLEPLAVTERLAI | SWGDGVRTLRG SAKFF
AALARANI NI VAI AQGSSERSI SVVVNNDDATTGVRVTHQVLFNTDQVI EVFVI
GVGGVGGAL L EQL KRQOSW.KNKHI DL RVCGVANSKAL L TNVHGL NL ENWQEEL
AQAKEPFNLGRL| RLVKEYHLLNPVI VDCTSSQAVADQYADFL REGFHVVTPNK
KANTSSMDYYHQLRYAAEKSRRKFL YDTNVGAGLPVI ENL QNL L NAGDEL MKFS
G LSGSLSY! FGKLDEGVEFSEATTLAREMGYTEPDPRDDL SGVDVARKLLI LA
RETGRELELADI El EPVLPAEFNAEGDVAAFNMANL SQL DDL FAARVAKARDEGK
VLRYVGNI DEDGVCRVKI AEVDGNDPL FKVKNGENALAFYSHYYQPLPLVLRGY
GAGNDVTAAGVFADLLRTLSWKLGV

>ecoli.nb2: 2792 to 3730: Frane 2 313 aa
ESDMWKVYAPASSANVSVGFDVLGAAVTPVDGAL L GDVWTVEAAETFSLNNLGR
FADKLPSEPRENI VYQCWERFCQEL GKQ PVAMILEKNVPI GSGLGSSACSWA
AL MAMNEHCGKPLNDTRLLALMGELEGRI SGSI HYDNVAPCFLGGMQLM EEND
| 1| SQQVPGFDEW. W/LAYPG KVSTAEARAI LPAQYRRQDCI AHGRHLAGFI HA
CYSRQPELAAKL VKDVl AEPYRERL L PGFRQARQAVAEI GAVASG SGSGPTLF
AL CDKPETAQRVADW.GKNYL QNQEGFVHI CRLDTAGARVLEN

.. €fc.

The OREF titles are constructed as follows:

<sequence title>: <start base> to <end base>: Frame <frame number>

<sequence length>
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Plasmid drawing with BioEdit

BioEdit provides tools for simple plasmid drawing and annotation in afairly quick and easy
manner. The following vector map for pBluescript SK+ (Stratagene) was drawn in afew
minutes using BioEdit. The featuresin this particular map were basically copied from the map
provided by Stratagene. Creating a new vector isjust as simple, though.

Drranwn with BioEdit version 432, 12198 Kpnl 653

Eco01091 661
Brme] 662
f1 (+) origin Apal 684
Xhel 669
lnc? Zall 6875

J Aecl AYR

HincII 677
Clal &85
HindIII 820
EcoRV 658
EcoRI 702
Pstl 712
Smal 718

BamHI 720

Spel T26

hal 732
Hotl 739
Eagl 739

EstDSI 742

Mepl 1158 Sarll 751
EistXI 752

ColE1 origin Sacl 760

polylinker
cloning sites

Emnl 2646

Hgzal 2577
Seal 2527

MzolIV 332

Foul 2417

AmpR

pBluescript SK+

7058 bp vl

MCS
I polylinker)

FP11081 2084

Sapl 1038

791 T3 Primer bl bed
5' AATTAACCCTCACTALAGGG 3!

EakDb3I Sall E

Saell BaglI Spal Dina I EcoRY Clal Recl Hhal Eiir

Sacl EaklI HoEI Hbal EamHI PabEI EcoRhI HindIII HincIl hpal

70 ACRRRREE B IO A Y e Ot B L AR A L A A RO O R PR RS A ISR I A C AN I AT QAT AC OO OGO IO CREERDREE
IR I TCERCC IO R T T 2 C R e RRCh IC T TRR IC ACC T At CORACEICC I ARG TR T AT ICEAATREC TR TR0 AR TRSREC ICCCCCCCRD

E' GRRALRCAGCTATGACCATG 3 3' CGGGATATCACTCAGCATAATG &'
827  M13 Deversze Primer 808 645 T? Primer 745

3'TGACCGGCAGCARRATG &'
El8 M1z Forward Primer 603

With the BioEdit plasmid drawing utility, sequences may be automatically converted into circular
plasmids with easy automated positional marking. Features, polylinker and restriction sites may
be easily added through the use of dialogs. When a sequence is made into a plasmid map, a
restriction map is silently run in the background, so restriction sites may be added by simply
selecting from adialog. They are added to the correct position on the map automatically. The
plasmid utility also provides simple drawing and labeling tools. These need to be improved and
expanded, however. Labels and drawn objects may be moved and scaled with the mouse. To
edit an object’ s properties, double click on the object.
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To create aplasmid from a DNA sequence, choose "Create Plasmid from Sequence” either from
the "Sequence” menu, or from the "Nucleic Acid" submenu of the "Sequence’ menu. When this
option is chosen, arestriction map will be run using the common commercial enzymes and stored
in memory. When the plasmid first comes up it will ssimply be a circle with 10 positional
markings and atitle in the center.

Restriction sites:

To add restriction sites, choose "Restriction Sites’ from the "Vector" menu. The following
dialog will appear: (Therewill not initially be anything in the "Show" dialog)

:.;" Mark Restriction Enzymes [_ (O] |

A "L Mest to the position indicates it ig unique
Othenwize, the site occurs between 2 and & times

Shio Don't Show
Enzpme Pozition Enzyme Fozition
NgoiIV 332 U - LeeITT 71 i’
EpnI s58 T AceIII 110&
Ecoll03T 661 T AceIIT 2348
BumogT B2 T AclT 2273
Apal GEd 1T e AcC1T ZEdE
*hol g3 1 _ J|Af1TIIT 1154 T
2all &75 T - AhldT 2047 T
Aol 576 T _ 1|&loT 178 U
HincIT &77 0T A1wNT 1570 1O
Clal &35 1T Apall lagg
HindIII &30 0T ApaLI 2714
EcoRV 598 1T ApaoT 33
EcoRI 70z U ;' ApoI 44 ;'

Apply & Cloge | Cancel

To display restriction enzymes on the map, select any enzymes desired on the right side (the

"Don't Show" box) and move them to the left using the il button. When "Apply & Close" is
pressed, these sites will be added to the map. An enzyme is specified as being a single-cutter
(unique) by a"U" after the cut site. If thereisno "U", then thefirst cut position is shown. Only
enzymes which cut 5 or fewer times are shown. To remove enzyme positions from the map,

highlight the enzyme(s) in the " Show" box and presstheil button to move them to the other
Side.

Positional marks:

The following dialog can be brought up with the "Positional Marks' option under the "V ector"
menu:
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:.;" Posztional Marks
Positional karks
Diivide info: S hiowy Dan't Show
1 2 a
|5 'I 592 3 —
|nterealz 183 4
1774 J 4]
2365 <£||6
7
2|
q
10
11
12 =
Apply & Cloze | Cloze |

Positional markings may be added individually by moving them to the "Show" box, or a set
number of divisional markings may be applied. To have no marks at al, choose "none" at the top
of the "Divideinto:" drop-down list.

Features:

To add afeature such as an antibiotic resistance marker, choose "Add Feature" from the "V ector"
menu. the following dialog appears:

=1 3

:j:".ﬁ.dd Yector Feature

Feature Mame If'l [+] cnigin

Start |4BU Line Colar - EI
End i Fill Calar %I

[T Crosses the origin
Type INl:urmaI Ao j

Apply & Cloze |

Cancel |

The choices of type are Normal Arrow, Wide Arrow, Normal Box and Wide Box. All of the
features in the above example are of the "normal” width. If the featureisan arrow, the direction
of the arrow will be determined by the start and end positions, and whether or not it crosses
position 1 (the origin).

When features or enzymes are added, their respective labels are added on the outside, centered as

well as possible over the site. The labels may then be selected with the selector tool and moved,
scaled or edited.

General Vector properties:
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Properties of the vector may be modified by choosing "Properties’ from the "Vector" menu:

2*Vector Properties

Twpe —— | Title: IpEIuescript5K+

& Circul I_ I
Ircular Stle: | SingleLine [F b ark Font | Feature Font |

' Linear

Length: IEEEE

Line Color I':I - ﬁl Lire *#idth |2 TI
FillColar 0 - %I Image Froperties

Folylinker Fram I??D Tao IEED Yector Size
¥ Show Palylinker belaw vector Wwidth ISEIEI Firelz
[ Show unique restriction sites in polylinker 'Image Size

[~ Mark beginning and end on map

Type Size IE vI

Height |600  Piggls

Tranzlation———— w720 Pirels
' nione
) Frame 1 ) Erame - Features If‘l [+] origin j

) Frame 2 ) Frame -2

i Frame 2 ) Erame -2 Add Mew |

Apply & Cloze | Cancel |

Delete |

A polylinker may be added to the bottom by specifying the beginning and end positions. The
polylinker is shown in "Courier New" font.

Features may be edited, added or deleted with thisdialog. To edit or delete an existing feature,
choose the feature in the "Features' drop-down and press the appropriate button. A new feature
may be added by pressing the "Add New" button.

At thistime only circular, single line plasmids are available. Thiswill be expanded later.
The "Font" buttons change the indicated default font. The fonts of feature labels may be changed

independent of each other, but positional markings are not created as individual selectable
objects.
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Drawing tools:

Very simple drawing tools are available which behave more or less like standard drawing toolsin
most programs. The order of objects may be changed in the "Arrange" menu, and objects may be
grouped and ungrouped from the "Arrange" menu.

Note: Scaling grouped objects does not work well, as the objects are scaled independently of
each other.

To edit an object's properties, double-click on the object, or select the object and choose " Object
Properties’ from the "Edit" menu.

Cut / Copy / Paste:

When an object(s) is copied in the plasmid utility, a structure is copied into memory for the use
of BioEdit, and a bitmap of the object or objectsis copied to the clipboard. Objects may
therefore be pasted into other applications as bitmap images.

Printing:

When printing, the map is drawn to the printer at the printer's resolution to avoid the pixellation
that occurs with a screen-resolution bitmap. The print interface is not very advanced, however.
A left margin and top margin may be specified in the "Print Setup” dialog (from the "File" menu)
At thistime there is no support for scaling output to the printer to defined print dimensions. The
size of the printed figure is determined by the ratio of printer resolution to screen resolution. The
full width of a screen set at 800 x 600 resolution corresponds to roughly 8.3 inches, which is
pretty close to the width of anormal paper page (8.5 inches). The plasmid itself scales dightly
small on the printer, and I’m currently trying to figure out why. The size relative to an 800 x 600
resolution screen isfairly close, however.

Moving the vector:
The vector may be moved around the page by first selecting it with the mouse (a dotted box will

be drawn around it to indicate it is selected), then dragging it with the mouse to its new location.
All of the labels and objects on the page will be moved accordingly.
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Sear ching functions

The following search options are available under the Edit menu. These functions were never
originally conceived very well and have evolved sort of sloppily. Searching functionality is
lacking in BioEdit at thistime and isin need of improvement.

Simple search: Find and Find Next

Thisis avery smple search function and needs to be improved. The menu option for
simple searching is found under Edit->Find. A standard search dialog is presented which allows
for searching of exact text strings (either case sensitive or insensitive) within selected sequences.
The search is aways performed downwards from the beginning of the document, and only
includes sequences whose titles are selected (the search is performed only upon the sequences,
and does not include titles). When the text is found, the first instance encountered is highlighted
in the document window. The current search position is remembered. To continue the search to
find the next instance, select Edit->Find Again (F3, by default). If Edit->Find is chosen again,
the search position is reset to the beginning of the document.

Find in Titlesand Find in Next Title

To highlight all titles containing specific text, choose Edit->Find in Titles. To highlight
the next title (either up or down) containing specific text, choose Edit->Find in Next Title. The
search is started at the last selected title in the specified direction.

Find Next ORF

When searching for ORFs, only sequences with selected titles are searched, and the search begins
after the last selected nucleotide. To search, choose Edit->Find Next ORF, or Sequence-
>Nucleic Acid->Find Next ORF. The search is performed according to the parameters specified
in the ORFs page of the preferences dialog. When an ORF is found, the sequence is highlighted
in the document window.
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Sear ch for user-defined motif

BioEdit 4.7.8 and above allows searching for user-defined sequence patterns according to
single-letter designations of nucleotides and amino acids. To search for a sequence within
selected sequences, choose Edit->Search for user-defined motif. The following dialog appears:

I® Motil zearch |

Pattern to zearch for:

= Mucleic Acid = dmino &cid Firnd Mext

....................................... Canicel

Enter the text to search for in the input box and choose the type of search.

In all four search types, a‘*’ isawildcard and can be used to specify aresidue of any identity. A
gap is specified by *-', *~" or “.".

Sear ch type:

Nucleic Acid: Assumes that the sequences being searched are all nucleic acid sequences. The
search is case insensitive, and depends only upon residue identity. DNA and RNA are treated
identically and aT isseen asidentical tot aU. Gaps areignored. The following convention is
followed for degenerate residue specifications:

R=AorG
Y=CorT/U
K=GorT/U
S=GorC
M=AorC
W=AorT/U
B=G,CorT/U
V=AGorC
A, GorT/U
A, CorT/U
A, G, CorT/U

ZTITO0
[ I T

Degenerate matching isone-way. An ‘R’ inthe query will matchan‘R’, ‘A’ or ‘G’ in the target,
but neither an *A’ nor a‘G’ in the query will match an ‘R’ in thetarget (an ‘R’ will always match
an ‘R’, however). For example: the query ‘aggryknncc**u’ will match all of the following
Sequences:

aggacgttccttt
aggguuuuccuuu
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agggcgecccttt

Amino Acid: Assumes that the sequences being searched are al amino acid sequences. The
search is case insensitive, and depends only upon residue identity. Gaps areignored. The
following convention is followed for degenerate residue specifications.

X = any of the twenty standard amino acids
B=DorN
Z=EorQ

Like for nucleic acids, degenerate matching isone-way. A ‘B’ inthe query will matcha‘B’, ‘D’
or ‘N’ inthetarget, but neither a*D’ nor a‘N’ in the query will match an ‘B’ in the target (a‘B’
will always match an ‘B’, however).

Standard one-letter amino acid codes are as follows:

A =Ala=aanine

C =Cys=cysteine

D = Asp = agpartate

E = Glu = glutamate

F = Phe = phenylalanine
G =Gly =glycine

H = His = higtidine

| = lle =isoleucine

K =Lys=lysne

L =leu=leucine

M = Met = methionine
N = Asn = asparagine
P =Pro = proline

Q = GIn = glutamine
R = Arg =arginine
S=Ser =serine

T = Thr = threonine

V =Val =vdine

W = Trp = tryptophan
Y = Tyr = tyrosine

Exact text match:
A case insenditive search is performed, however, gaps (‘-', ‘~' or *.") areignored and **’

represents any character. Notethat a‘T’ and a‘U’ are different, even if the sequence typeis
nucleic acid, and no degenerate identities are considered.
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Exact including gaps:

Like an exact text match, but gaps are not ignored. A gapisdtill a‘-', *~" or ‘.’, however, and the
search does not have to exactly specify the gap character present. A **’ isstill awildcard in this
search and may be used to specifiy a character of any identity.
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Preferencesfor translation output and ORF searching

To set parameters for ORF searching or the format of trandations of nucleic acid sequencesvia
the Sequence->Nucleic Acid->Trandate-> ... menu options, choose Options->Preferences-
>0ORFs:

3 Preferences [_ O]

Mutuallnfnrmatinn] Envariatinn] Fotential Paiings DRFs lEDnsensus] Painvize .-'-‘-.Iignment] General]

ORF searching:

Start codon |ATG Tl Stop codons |UTGA : TAA  TAG

Min. OFF zize |50 aming acids

Translationz with codon ugane summary

R ezidus Codes

[v Show codon uzage
f* Three-leter codes

" One-letter codes

Tranzlations of Selected Test
" Show Selected nucleic acid only
{« Show entire nucleic acid sequence

Save kClose | Cancel

ORF searching: The start codon used for ORF searching will generally be ATG, however, you
may wish to search allowing for aternative start codons. To allow more than one start codon at a
time, type in the codons separated by a“;”. For example, to allow ATG and TTG, type
“ATG;TTG” in the start codon box. The same syntax is used for stop codons. If you would like
to allow read-through of a codon (for example, UGA), remove It from thelist. The preferences
will be saved for all subsequent searches.

When searching for ORFs, only sequences with selected titles are searched, and the search begins
after the last selected nucleotide. To search, choose Edit->Find Next ORF, or Sequence-
>Nucleic Acid->Find Next ORF.

Formatted nucleic acid translations are performed by choosing Sequence->Nucleic Acid-
>Trandate, then either Frame 1, Frame 2, Frame 3, or Selected. If the “ Show codon usage” box
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is checked, a summary table is reported as described in Nucleic acid translation with codon
usage.

Conservation plot view

Sometimes it can be convenient to plot an alignment with reference to a standard sequence
(usually the top one), where any residues down a column which are identical to the standard at
that point are plotted as a specific character (usually adot). BioEdit offerstwo basic waysto do
this:

1. Choose "Alignment->Plot identities to first sequence with adot" to create a whole new
sequence alignment document that has identities to the first sequence plotted asadot. Inthis
new document, the sequence data for residues converted to dots is not retained, and the new
alignment doc is intended only for generating a picture of an alignment. 'Y ou may then choose
File->Graphic view and uncheck the option for similarity and identity shading to make afigure
out of the plot.

2. For adynamic view of the aignment which plots identities to a standard sequence as a

TTAHE

specific character, press the ““&:| button on the toolbar, or choose the menu item "View-
>Conservation Plot". When the conservation plot button is down, you have the option to specify
the character to be used for plotting identities:

I| The default isadot, but theoretically any character can be used. Redlistically,
though, a period or space (blank) is generally the easiest to see.

Y ou can at any time change the reference sequence by right-clicking the title of the sequence you
would like to have as reference. The reference sequence is handled internally by its number in
the list, though, so if you move the sequence up or down, you will have to right-click itstitle

again.
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Basic Analysis Tools

BioEdit comes with asmall (and somewhat uncoordinated) set of analysis functions and tools,
which are the focus of the rest of the docuemntation. Analysis features are split into two
categories.

1. External, independent programs which are written by other authors and are either distributed
with BioEdit or may be obtained from an outside source and can be run from the BioEdit
interface. BioEdit offers a somewhat general command line generator that may be configured
through a graphical interface to launch external analysis programs and feed sequence datato
them to facilitate an easier analysis environment from a single interface.

2. Functions which are built directly into BioEdit.

External Accessories

Installing TreeView:

TreeView is aphylogenetic tree viewing program written by Roderic D.M. Page. Previous
versions of BioEdit included a distribution of the TreeView executable and supporting libraries
in the appsfolder. At the request of the author full TreeView installation is now distributed with
BioEdit. Thisinstalation is contained within the file called TreeView.zip.

Toinstal TreeView, unzip the file to atemporary directory, then run the program called
"setup.exe" which will be created. TreeView will install itself on your system.

To configure TreeView to run through the accessory apps menu of BioEdit, choose
Add/Remove/Modify an Accessory Application from the Accessory Application menu. Inthe
"Name of Accessory" box, type “TreeView”. Press"Specify" next to the “Program” Box and
browse to the new location for the TreeView.exe program. Check the box called “Prompt for
input file”. In the “General Description” box, type “ TreeView version 1.5.2. Copyright Roderic
D.M. Page, 1998. r.page@bio.gla.ac.uk. http://www.taxonomy.zoology.gla.ac.uk/rod/rod.html”
without any carriage returns. Then press “Add/ Modify” at the bottom of the dialog. Upon
closing the window, you will be prompted to have BioEdit close and restart. For more
information on installing accessory applications, see Configuring and Using External
Applications.
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Configuring and Using External Applications

BioEdit provides an interface to add and configure external applications which will be added to
the “ Accessory Application” menu of alignment documents. Once an application is properly
configured, it can be run viaagraphical interface created by BioEdit when its menu option is
selected. Although any application may be configured to be launched through BioEdit, DOS and
Win32 programs which can accept command line parameters to fully perform an analysis are
most convenient. BioEdit may be configured to automatically feed sequences to the application,
then automatically load the output when the application is finished. Multiple output files may be

opened, and the output of one program may be configured to be automatically opened by another
program.

:;‘ Configure Accessory Applications: BioEdit version 5.0.0

Mame of Accessany: IFitch link, for Protdist - Fitch tree j Open Delete | Frint Configuration | Clear Form |
Pragrar: I<BiaEdit>‘~.apps'~.Fitch.e:¢e Specify  |Use "<BioEdit>" to specify the BioEdit inztall directory

[~ Autofeedseqs [~ szeparatefiles [ Specific name [or base name) ||7 Dan't use interface [ D't create menu item

[~ Degap zequences  File name: [or base name] : . -
—Farmnat II: E:E;E: ;2: :Llft;tl.,lftllﬁle [ Open with extemal program ~ Specify |
* Fasta " GenBank T PHYLIF3 PHYLIF 4 [~ Open as dignment | Pragrar: I

" MBRF/FIR 1 MSF i GCG i EMBL [~ Open as test

[T Tiles 10 chars or less [~ Mo duplicate tiles [~ Change spacesto ' ' [ Open with ECCESSDI}'I j
command-line formatting for input and output; Add inout file b Al

™ Space between input prefis and cormmand [~ Space between output prefis and commarnd r RS e T

i~ at beginnin = atend
™ Use input prefis I ™ Input name required I ™ Arbitrary [ From stdin | amnng |

[~ Add output file to command line
™ Use cutput prefis I [ Dutput name required I [ Arbitrary [~ To stdot |_r~ stheginning  C atend J
CheckBoxes: I j add ¢ Mu:u:lifyl Delste I

Inputs: | =] bdd/Modty|  Delete |

Default command line: I

Additional output files: Add / Modify
|lreefile j Delete

*Mote: If the calling order iz important, write a specific default command line and specify file names accordingly

[ “iew documentation option  Specify dac fil | [~ Redirect general stdaut ba file: I
Documentation File: I<BinEdit>\apps"~Fitch.doc ¥ Redirect general stdin from file: I<BioEdit>\apps\ph_l,JIi Specify |

[ Include an options box [to type in command-ine paramters] | Cumrent Canfiguration:

General deseription: Dan't use any returns BioE dit werzion 5.0.0 acceszary application configuration 3
FITCH wersion 3.5¢ - Fitch-Margoliazh and - 12¢31/00 %5756 PM

Least-Squares Distance Methods. [c] Copuright

1986-1993 by Jozeph Felsenztein and by the “eh !
Uriversity of “Washington, “ntten by Jozeph Program: <BioE dit>apps'Fitch.exe

Felzenstein. Permiszion iz granted to copy [the I‘IT Lotorf oo M“I _>|_|

| |

Add /£ Modify | Cloze | Help

Acceszory: Fitch link for Protdist -» Fitch tree
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Adding and configuring a new application

BioEdit v2.0 and later offers a graphical interface for configuring external applicationsto be run
from a BioEdit alignment document. Unfortunately, there is no way to do this without knowing
how to run the application independently of BioEdit. A few programs come with the BioEdit
installation and are configured already. Permission has been granted by Joe Felsenstein to use
PHY LIP programs with BioEdit (asong as no money changes hands). Permission has also been
obtained from Roderic D.M. Pageto distribute TreeView. TreeView isno longer pre-configured,
however. At the request of the author, BioEdit now comes with the TreeView install package,
which is extracted into the main installation folder upon installing BioEdit. For more
information, see Installing TreeView.

To add a new application to be included in the “ Accessory Applications’ menu, choose “Add /
Modify / Remove an Accessory Application” from the “ Accessory Applications’ menu.

There are severa settings which must be specified for an accessory to be run successfully
through BioEdit. Many settings will not be required for many applications and each
configuration will be different, as programs are written differently by different people. One must
know how to run the program via a command line in order to configure BioEdit to run the
program. Refer to the documentation of your accessory application to learn how to run it before
trying to configure it as an accessory. The following options are present in the configuration
interface. Only thefirst two are universally required for all applications.

* Nameof Accessory: Thisisthe name that will appear in the “ Accessory Applications” menu.
This can be any name you want. It isrecommended to keep it relatively short, however, asit
will be amenu option in al alignment documents.

* Program: The absolute or relative path to the program, including the program name (usually
an .exefile, but could be a.com or a.bat file). To specify the path relative to the BioEdit
installation directory, specify the main installation directory as “<BioEdit>" (not case
sensitive). For example, an application named “MyApp.exe” might be placed in the “ apps’
directory. To allow the whole BioEdit directory to be moved without causing a problem with
finding the application, specify the path as “ <BioEdit>\apps\MyApp.exe’. (Note: do not
include the quote marks). Alternatively, if the absolute path will be specified, you may
browse the disk to find the application by pressing “ Specify”.

» Automatically feed sequencesto App: If the program analyzes sequence or alignment data
(such as ClustalW or certain PHY LIP programs), you may choose to have the sequences
automatically fed to the application. Thisisone of the most useful benefits of running the
program directly from an alignment editor. An application that takes only one or several
sequences may be done this way also, as BioEdit will only feed selected sequences at runtime
(if no sequences are selected, they will all be selected automatically).

» Specific File name required (for auto-fed sequence data): Some applications expect a
specific input file name. For example, the PHY LIP programs all expect to process afile
called “infile”. If thisisthe case, check this box and enter the expected namein the “File
name” input box. Don’t include a path, since the file will be automatically saved to the
directory containing the application.
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Degap sequences. Some applications require alignment data (such as DNAmI, Protdist,
DNAdigt, etc.) and gaps will beincluded in the input. Other programs (e.g. search programs
such as BLAST) may take simple sequence data rather than alignment data. In these cases,
gaps must be removed or they will be viewed as residues.
Format (for auto-fed sequences): Eight file formats are available for auto-feeding alignment /
sequence data to programs: (if you have an application that requires a different format, you
may have to configure the application to take a certain file name, choose not to auto-feed the
sequences, and convert the file to the correct format before running the program -- or simply
run the program separately. If it would very convenient to have it run through BioEdit,
simply email me at tahall2@unity.ncsu.edu with file format name and specifications and it
would be aminor thing to write an export filter and add it to the accessory applications
method of BioEdit. If you need this, feel free to email me and | will mail back with an
address where the new copy of the program may be picked up and when (or if | can’t for
some reason, | will mail back and tell you that). Currently available formats are:

 Fasta

* GenBank

e PHYLIP2/3.2(PHYLIP3)
« PHYLIP4

* NBRF/PIR

* MSF (viaReadSeg.exe: Don Gilbert’ s sequence conversion filter).

* GCG (viaReadSeg.exe)

« EMBL (viaReadSeq)
Prompt for input file: you may want to be prompted at runtime for an input file. BioEdit will
produce an open filedialog. The file name will be fed to the external program.
Y ou may want BioEdit to prompt you at runtime to specify an output file name to feed to the
program.
Open as aignment: The main output of the program may be opened as a new alignment
document. (By default, there is expected to be one main output file, however, thisis often
not the case, and additional output files may be specified in the box titled “ Additional output
files:” -- thisentry could be left blank and a single output could be specified as an additional
output. Functionally, this would make no difference).
Open astext. If the output isatext datafile, it may be opened astext in the BioEdit rich text
editor.
Open with external program: Perhaps the program exports tabular or matrix data that you
would like to view in a spreadsheet program such as Microsoft Excel. Y ou may specify any
external program to be launched and open the output automatically. Y ou may browse the
disk by pressing “ Specify”. You may aso specify apath relative to the BioEdit installation
directory with “<BioEdit>".

Note: An output file may be opened as a new alignment, as text and by an externa

program all at the sametimeif you want.
Useinput prefix: Some programs expect a specific prefix at the command line to specify the
input file, output file, the input of specific parameters, or all of these things. Other programs
may expect the input, output and parameters ssmply typed in a specific order. If you program
requires a prefix to specify the input file, check this box and enter the prefix exactly in the
associated edit box. Note: |If the prefix and the file name will be separated by a space, type
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that space after the prefix when configuring the application. For example, one application
may expect to see “-i inputFile” while another may expect “input=inputFile”. Depending on
how the applications are written, the first one may not work if the space is not included, and
the second one may not work if a space isincluded.

Use output prefix: Same as input prefix.

Input name required: Some applications require that an input file name be specified in the
command line (e.g. ClustalW). Others may expect a specific file name which therefore is not
specified at the command line (e.g. PHYLIP programs). If the application expects to be
given the name of the input file at the command line, check this option.

Output name required: Same as “ Input name required”

Input or Output name arbitrary (check boxes labeled “Arbitrary”): Sometimes afile nameis
required at the command line, but can be any file name, aslong asit is specified correctly. If
thisisthe case, you may simply check the “Arbitrary” option(s) and BioEdit will assign input
and/or output files arbitrary names. For example, ClustalW is configured to automatically
feed sequences to the application, then automatically open the output as an alignment. The
“Input name required” option is checked, and so isthe “Arbitrary” option. When ClustalW is
run through this interface, input and output files are given the names “~inTemp.tmp” and
“~outTemp.tmp”, respectively.

From stdin and To stdout: Some programs (such as FastDNAmMI™) expect to get input from
stdin and/or send output to stdout. Stdin and stdout are the standard system input and output
streams and the defaults are from the keyboard and to the screen, respectively. To redirect
the input or output from stdin or stdout to afile, which is necessary to run the program
automatically, choose the appropriate checkbox(es). Most programs that expect data from
stdin expect it to be redirected from afile anyway. Stdout must be redirected to afilein order
to be able to save the data and/or open it up in BioEdit or another program.

Checkboxes: The Interface created by BioEdit to run external applications may include
yes/no choices in the form of checkboxes so that certain program options may be set easily at
runtime. These checkboxes will be drawn on the interface created by BioEdit to run the
program. Theoretically, up to 50 checkbox options may be included per application. This
limit was set because | had a hard time imagining an application that would allow anywhere
close to that many options and not already have its own graphical interface. Most programs
will probably have none, and those that do will usually have fewer than 5. To add a
checkbox, type the Caption you want to appear on the interface in the Checkboxes” drop-
down list box, then pressthe “Add / Modify” button. A dialog will appear in which you may
specify the default state of the check box (checked or unchecked), and also the command line
action to specify for each choice. If no command line parameters will be added for a
particular choice, leave it blank. Press OK for the changesto be entered. To modify an
existing checkbox, choose it in the drop-down list and press“Add / Modify”. To delete a
checkbox, choose it from the list and press “ Delete”.

Inputs: Some programs may allow or expect specific data to be entered which affects
program execution (for example, CAP assembly asks the user for the minimum base overlap
and the minimum percent match). For this purpose, input boxes may be included on the
accessory application interface. Add, modify or delete an input the same way you would a
checkbox. Each input may also have associated with it a checkbox, which allows the option
to choose whether or not to use the input at runtime. In the configuration dialog, you may
specify acommand prefix for the parameter in the command line (may or may not be required
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-- if not, leave it blank), and a default value that will appear as the input text in the interface.
If you want an associated checkbox, you must check this option and enter the caption for the
checkbox, as well as the default state of the checkbox. Up to 50 inputs are theoretically
allowed, all with the option for associated checkboxes.

Additional output files: Up to 10 different output files may be specified and specifically dealt
with, in addition to the “main” default output file. *** Note: It isassumed here that the
additional outputs are automatically generated by the program and the file names are not
specified at the command line***. If thisis not the case, thisisnot realy aproblem. Simply
either add the appropriate parameters to the default command line or include an edit control
on the program interface to enter them at runtime (see below). Add, modify or delete
additional output configurations the same as checkboxes and inputs. Each additional output
configuration expects a specific file name. In most cases, do not enter a path (just the file
name), as most programs will simply save the output in the directory they arein. If aspecific
path isrequired, it may be included. Some programs (such as Clustal\W) may produce an
output file which is given the same name as the input file, only with a different extension. In
this case, specify the filename as “<infile>.ext” (for example, if the input file nameis
“temp.tmp” and the output is specified as “<infile>.out”, then the file should be named
“temp.out”). The output may be opened as an alignment, as text, by an external application,
or any combination of these three options. If the output is not opened by an external
application, the temporary file which contains it will automatically be deleted (you must save
any information you wish to keep).

Default command line: Certain parameters may be desired for al runs of the program. In
this case, specify these in the default command-line box. For example, ClustaW allows
output in GCG, GDE, PHYLIP or PIR (NBRF) formats. Since BioEdit read NBRF/PIR files
internally, “/output=PIR” may be specified as the default command line to provide an output
that BioEdit quickly recognizes as an alignment file.

Add input file to command line: If this box is checked, BioEdit will automatically construct a
command line that includes the input file and command prefix (if there is one), depending on
the configuration for the input file. 1t may be necessary to leave this box unchecked and
write the input file specs right into a default command line if the absolute position in the
command lineisimportant and it is not at the beginning or end. Otherwise, select either the
“at beginning” or “at end” option to specifiy where to place the input file name in the
command line.

Add output file to command line: same as for input file

View documentation option: If documentation comes with the program, or you are
configuring the program for other people who are less familiar with it, you may want to
include an automatic link to the documentation. Thiswill work if the documentationisin a
single text or rich text file. If this option | chosen, you may specify the doc file by pressing
“Specify” or by entering the path in the “ Documentation file:” box. The designation
“<BioEdit>" may be used to specify a path relative to the BioEdit installation directory. |If
this option is chosen, a button will appear on the interface with the label “View
Documentation”.

Include an options box (to type in command-line parameters). If you would like an input box
to appear on the interface which allows you to enter additional command-line parameters at
runtime, check this option. If you have an application which requires a very unique
arrangement of command line options, but is still convenient to run through BioEdit, you
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may create an interface that has only this input box and simply enter the command-line at
runtime.

Redirect stdout. Some programs may print data or progress information to the screen when
running. If you would rather have thisinformation saved to afile and opened by BioEdit for
viewing later, choose redirect stdout, specify afile name, and configure that file to be opened
as an additional output file (see above).

Redirect stdin: Some programs, such as programs in the PHY LIP package, provide amenu
when launched that allows settings to be specified. If a specific set of settings will be used al
of the time, afile may be created with the exact series of keystrokes that would specify these
settings from the menu(s), then stdin may be redirected to this file rather than the keyboard.
So far, this does not seem to work when programs are launched from within BioEdit. There
does not seem to be any good reason that it should not work however, and this option has not
been completely removed because | planto fix it in the future. For now, I'm not sure if the
option will work in some cases and not in others, but it is probably best to not use this option
until it isfigured out.

General description: In this box, type a description of the program that will be printed on the
interface at runtime. The description may be as long as you want, but it must be entered as a
single line of text. If any carriage returns are entered, the description will be truncated at the
first return character. Thisis because of the way the configuration datais stored. This
description will often contain a short description of the program and a reference to the
author(s).

“Add/ Modify”: Pressing this button will save the entered information and list the current
configuration in the “ Current configuration” box.

Pressing Close will close the dialog without updating the information.
To print the current configuration, press the “Print Configuration” button.
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Modifying an existing configuration

To modify an existing application configuration, first bring up the configuration dialog by
choosing the “Add/ Remove/ Modify an Accessory Application” from the “ Accessory
Application” menu. Pressthe arrow on the “Name of Accessory” drop-down box to drop down a
list of currently configured applications. Choose the application you would like to modify and
press “Open”. Reconfigure the application the way you want.

Y ou may modify the information associated with checkboxes and inputs at any time by choosing
the title of the checkbox or input you would like to modify from the drop down lists associated
with them, then pressing the appropriate “Add / Modify” button. Y ou may delete any checkbox
or input by highlighting its name (or typing it) in the appropriate drop-down box and pressing the
associated “Delete” button. Likewise, additional output file handling may be configured in the
same manney.
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Removing an accessory application

To remove an accessory application from the configuration, simply bring the accessory
applications dialog up, then choose the name of the application you would like to remove from
the drop down list labeled “Name of Accessory”. Pressthe “Delete”’ button to remove the

accessory.
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Storage of Accessory Application Configuration I nformation

BioEdit accessory application information is stored in afile called “accApp.ini” whichisfound
in the “apps” folder of the BioEdit installation. Thisfileis organized in the same manner asthe
BioEdit.ini file found in your Windows directory. The configuration information for the
ClustalW Sample configuration is shown below. Asyou can probably see, the information isa
little cryptic asis, though it can be deciphered with aminimal effort. It ismuch easier to
configure applications using the graphical interface than directly editing this configuration file,
and amore meaningful summary of each configuration showing the same information as below
is displayed on the interface and may be printed from the dialog as well. Thisfile can be directly
edited, however, following the general format laid out below. Checkboxes are designated as
c<checkbox #>, starting at 0, and inputs are i<input #>, starting at 0. All of the categories of data
are written as shown below. Parameters which are not used or have no value are written into the
configuration as blanks. Vaueswhich may be either true or false are written as 1 or 0,
respectively.

[ClustalW multiple alignment program]
Program=<BioEdit>\apps\clustalw.exe
Auto-Feed=1

Degap Sequences=0

Auto-Feed File Format=1

Auto-Feed File Name Required=0
Specific File Name=

Prompt for Input File=0

Prompt for Output File=0

Open Output as Alignment=1

Open Output as Text=0

Open Output with External Program=0
External Program Name=

Input File Prefix=/INFILE=

Output File Prefix=/OUTFILE=
Specify Input File Name=1

Specify Output File Name=1

Input File Name=

Output File Name=

Input File Prefix Required=1

Output File Prefix Required=1

Input File Name Arbitrary=1

Output File Name Arbitrary=1
Redirect input from stdin=0

Redirect output from stdout=0

Default Command Line=/output=PIR
View Documentation Option=1
Documentation File=<BioEdit>\apps\clustalw.txt
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Description=ClustalW: Thompson, J.D., Higgins, D.G. and Gibson, T.J. (1994). CLUSTAL W:

improving the sensitivity of progressive multiple sequence alignment through sequence
weighting, position specific gap penalties and weight matrix choice. Nucleic Acids Research,

submitted, June 1994.

Include Additional Options Box=1

Redirect Genera stdout=1

Stdout Redirected Filename=clustal.sto
Redirect General stdin=0

Stdin Redirected Filename=

c0 Title=Full Multiple Alignment
cOYES=/ALIGN

cONO=

c0 Default=1

cl Title=Calculate NJ Tree

ClYES=/TREE

CcINO=

cl Default=0

c2 Title=FAST Algorithm for Guide Tree

c2Y ES=/QUICKTREE

c2NO=

c2 Default=0

10 Title=Number of Bootstraps

i0 Prefix=/BOOTSTRAP=

i0 Default=1000

10 CheckBox=1

i0 CheckBox Title=Bootstrap NJ Tree

10 CheckBox Default=1

Additional Output O Name=<infile>.dnd
Additional Output 0 Open as Text=0
Additional Output 0 Open as Alignment=0
Additional Output 0 Open with External Program=1
Additional Output O External Program Name=<BioEdit>\apps\treev32.exe
Additional Output 1 Name=clustal.sto
Additional Output 1 Open as Text=1
Additional Output 1 Open as Alignment=0
Additional Output 1 Open with External Program=0
Additional Output 1 External Program Name=
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Accessory Application Example: Configuring ClustalW to run through a
custom BioEdit interface

Below is a step-by-step example of configuring an external application to run from and work
with BioEdit. Thisexample configures ClustalW, for which an interface was already directly
programmed into BioEdit before addition of the configuration interface. You will see that, after
configuring ClustalW correctly, calling the new menu option will bring up an interface that looks
dlightly different than the one included in BioEdit, but is functionally identical. Also, if you run
ClustalW from the new interface, compared to the old one, it will runin a“thread” separate from
the main BioEdit application, which means that you can continue to work on other stuff while the
accessory application runs simultaneously in the background.

*** Step 0: Before step 1 of any application configuration, you must know what command line
options are required and what their specific designations are. If you are dealing with a new
program you have not used before, you probably need to read the documentation.

To configure ClustalW:

» Bring up the configuration dialog by choosing “Add / Remove / Modify an Accessory
Application” from the “ Accessory Application” menu.

* Type“ClustaW Example Application” in the input labeled “Name of Accessory”.

» To specify the program executable, press the “ Specify” button and choose “ clustalw.exe” (the
directory browser should start you off in the “apps’ directory which contains clustalw.exe.
Replace the path up through “BioEdit” with “<BioEdit> to specify arelative path. For
example, if, after clicking on clustalw.exe, the Program box contains the text
“C:\BioEdit\apps\clustalw.exe”, change it to “<BioEdit>\apps\clustalw.exe’ .

» check the “ Automatically feed sequencesto App” box.
* Check “Fasta’ asthe output format.

» If you want the sequences degapped before running ClustalW, check the “Degap Sequences’
box. Otherwise leave this box unchecked (it shouldn’t really matter in this case)

» Check the box titled “ Open output as new alignment” to have BioEdit automatically open the
new alignment as a new document when Clustal W is finished running. Leave other boxesin
this area unchecked and ignore the * open with external program” option.

» Check both “Useinput prefix” and “Use output prefix”. These optionstell BioEdit that the

command line must use specific prefixes to indicate which parameter specifies the input file
name and which specifies the output file name to ClustalW.
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For the “Input file command prefix”, type “/INFILE="
For the “Output file command prefix”, type “/OUTFILE="

Check the boxes labeled “ Input name required” and * Output name required”. Thesetell
BioEdit that ClustalW that the names of the input and output files are needed (they are not
some set file name that the program always looks for).

For both, check the “Arbitrary” box to indicate that any arbitrary file name may be used for
the input and output names, as long as ClustalW is told those names.

Leave the boxes called “ Space between input prefix and command” and Space between
output prefix and command” unchecked.

Make sure that the box for “Add input file to command line” is checked and check the “at
beginning” box.

Check the “Add output file to command line” and again check the “at beginning” box.
Next, we will add the same checkbox options as seen on the internal ClustalW interface:

In the “CheckBoxes input, type “Full Multiple Alignment” and press“Add / Modify”. The
same name will appear asthe “Title” parameter in the dialog that pops up. For the
“Command if checked” parameter, type “/ALIGN”. Leavethe“Command if not checked”
input blank. Check the “Default checked” box.

In the “ CheckBoxes input, type “ Calculate NJ Tree” and press “Add / Modify”. For the
“Command if checked” parameter, type “/TREE”. Leave the“Command if not checked’
input blank. Do not check the “Default checked” box.

Create acheckbox caled “FAST Algorithm for Guide Tree”. For the “Command if
checked” parameter, type “/QUICKTREE”. Leavethe“Command if not checked” input
blank. Do not check the “Default checked” box.

Create an input called “Number of Bootstraps’. For the “ Command prefix” parameter, type
“/IBOOTSTRAP=". In the “Default value input, type 1000. Check the box labeled
“Associate a checkbox”. Name the checkbox “Bootstrap NJ Tree” and choose the default
state as checked. Thiswill allow you to choose whether or not to bootstrap, and, if done, the
number of bootstraps.

In the “ Default command line” box, type “ /output=PIR”. This specifies that the program
save the output as an NBRF/PIR file.

Check the “View documentation option” box, then press the “ Specify doc file” button.
Choose “clustalw.txt” as the documentation file. Modify the beginning of the path to the doc
file as <BioEdit>.
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»  Check the box labeled *Include an options box (to type in command-line parameters)”.

* Inthe“General description” box, type “ClustalW: Thompson, J.D., Higgins, D.G. and
Gibson, T.J. (1994). CLUSTAL W: improving the sensitivity of progressive multiple
seguence alignment through sequence weighting, position specific gap penalties and weight
matrix choice. Nucleic Acids Research, submitted, June 1994.” , without using any return
characters (type as a single continuous line of text).

» If TreeView has already been installed, in the “Additional output files’ box type
“<infile>.dnd” and pressthe “Add / Modify” button next to this box. Inthe dialog that
appears check “Open with external program”, then Choose “ specify” and browse to thefile
treev32.exe (the executable for TreeView -- thiswill likely be in C:\Program Files\Rod
Page\Tree View if you chose the defaults when installing). This specifiesthat afile will be
created by ClustalW with the same base file name as the input, but with an extension of .dnd.
Thisfileis aphylogenetic tree, and may be opened by treev32.exe, which is the executable
for TreeView version 1.5.2, Copyright Roderic D.M. Page, 1998. Thiswill cause this output
file to be opened automatically with TreeView.

* Inthe*“Additional output files’ box type “clustal.sto” and pressthe “Add / Modify” button
next to this box. In the dialog that appears check “ Open as new text document”. Then press
OK.

» Check the “Redirect genera stdout to file’ and enter “clustal.sto” in the input box. Thiswill
cause the general screen output to be directed to afile called “clustal.sto” which will be
brought up as atext document in BioEdit after ClustalW is finished executing.

* Pressthe“Add/ Modify” button at the bottom of the dialog. A configuration summary
should come up in the “Current Configuration” box which looks something like this:

Bi oEdit version 4.7.1 accessory application configuration
7/31/99 10:40:51 PM

Accessory: O ustal Wexanpl e application
Program <Bi oEdi t >\ APPS\ C ust al w. exe
Aut o- Feed Sequences: Yes
Aut o- Feed File Format: Fasta
Degap sequences: No
Prompt for nane of input file: No
Open output as new al i gnnent: Yes
Open output as text docunent: No
Open output with external program No
Prompt for nane of output file: No
Prefix required for input file: Yes
Space after input prefix: No
Prefix for input file: /INFILE=
Use arbitrary default input file name: Yes
Prefix required for output file: Yes
Space after output prefix: No
Prefix for output file: /OUTFILE=
Specify input file name: Yes
Use arbitrary default output file nane: Yes
Input file nane:
Specify output file nanme: Yes
Qutput file namne:
Add input file to command line: Yes
Add input file at begi nning of conmand Iine.
Add output file to command line: Yes
Add output file at begi nning of conmand Iine.
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Redirect input fromstdin: No

Redi rect output from stdout: No

Addi tional output file 1:
File Nane: <infile> dnd
Open as new text document: No
Open as new al i gnment docunent: No
Open with external program Yes

Ext ernal program nane: C:\Program Fil es\ Rod Page\ TreeVi ew\treev32. exe

Addi tional output file 2:
File Nanme: clustal.sto
Open as new text document: Yes
Open as new al i gnment docunent: No
Open with external program No
Default command |ine: /output=PIR
Redi rect general stdout: Yes
Redi rect general stdout to file: clustal.sto
Redi rect general stdin: No
Add option to view docunentation: Yes
Docurment ation file: C \BioEdit\APPS\ d ustal w.txt
I nclude a box for additional command-Iline options: Yes

Description Clustal W Thonpson, J.D., Hggins, D.G and G bson,

T.J.

(1994) .

CLUSTAL W

improving the sensitivity of progressive nultiple sequence alignnment through sequence weighting,

position specific gap penalties and weight matrix choi ce.

1994.
CheckBox 1:
Title: Full Miltiple Alignnent
Conmand when checked: /ALIGN
Command when not checked:
Default state: Yes
CheckBox 2:
Title: Calculate NJ Tree
Command when checked: /TREE
Conmand when not checked:
Default state: No
CheckBox 3:
Title: FAST Algorithmfor Cuide Tree
Conmand when checked: / QUI CKTREE
Command when not checked:
Default state: No
I nput 1:
Title: Nunber of Bootstraps
Command Prefix: /BOOTSTRAP=
Def aul t val ue: 1000
I ncl ude associ at ed CheckBox: Yes
Associ at ed CheckBox name: Bootstrap NJ Tree
Associ at ed CheckBox default state: Yes

* Press“Close” to closethedialog. You will get a message asking if you want to restart

Nucl ei ¢ Aci ds Research,

submitted,

June

BioEdit for the new changes to take effect. Press“Yes’” and wait for BioEdit to close down

and restart. Now the menu option “ ClustalW Example Application” should appear in the

“Accessory Applications’” menu.

*  Open afile containing some homologous sequences to be aligned. Choose “ Clustal W
Example Application” from the “Accessory Applications’” menu. Y ou should see the
following interface, which is functionally identical to the one incorporated directly into

BioEdit.
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Clustalw’ multiple alignment program Interface

Chuztals's Thompzon, 1.0, Higgine, D.G. and Gibeon, T.J. [1934]. CLUSTAL W improving the zensitiviig ;I
of progressive mulliple sequence alignment through sequence weighting, postion specific gap penalties
and weight matrnx choice. Mucleic Acids Research, submitted. June 1334, LI

[+ Full Multiple &ligrrmert
[T Calculate NJ Tree
[T FAST Algaonthm for Guide Tree

[+ Bootstrap MJ Tree
I'I Q00 MHurmber of Bootstraps

"ﬁ.dditiunal O ptiar

Cancel Wiew Documentation

105



BLAST

A BLAST (Basic Local Alignment Search Tool) search is often the most convenient method
for detecting homology of abiological sequence to existing characterized sequences. BLAST
looks for homology by searching for locally aligned regions of identity and/or similarity between
aquery sequence and sequencesin a database. The agorithm works by the following general
method:

1. A query sequenceisdivided into short sequences (called words, ca. 3 to 8 residues, depending
on whether it’ s protein or nucleic acid).

2. A table of all sequences of the same word size which can pair with each of the words from the
guery sequence with a score above a defined threshold is constructed (the lookup table).

3. The database sequences are scanned for occurrence of sequences in the lookup table.

4. When aword is found in the database which can align to aword in the query over the critical
threshold, the alignment is extended in both directions. This extension continuesin both
directions as long as the length of the extension does not exceed a defined limit without further
increasing the score of the alignment.

5. If, when an extension is terminated, the total sub-alignment score is above another defined
threshold, the alignment is reported.

6. When athreshold alignment is produced, that particular database sequence is re-scanned for
other non-redundant high-scoring segment pairs (HSPs) which score above yet another defined
cut-off (the sum of several non-significant sub-alignments within the same two sequences can,
when taken together, indicate significant similarity indicative of homology).

7. A statistical measure is reported which indicates the probability that a similar-scoring HSP or
set of HSPs found for a given query would result from searching the same database with a
randomly-generated sequence of the same length as the query.

For areference on BLAST, see:

Altschul, Stephen F., Warren Gish, Webb Miller, Eugene W. Myers, and David J. Lipman
(1990). Basiclocal aignment search tool. J. Mol. Biol. 215:403-10.

and, for the newer gapped BLAST and PSI-BLAST versions,

Altschul, Stephen F., Thomas L. Madden, Algjandro A. Schéffer, Jinghui Zhang, Zheng Zhang,
Webb Miller, and David J. Lipman (1997), "Gapped BLAST and PSI-BLAST: anew generation
of protein database search programs’, Nucleic Acids Res. 25:3389-3402.

for a description of the newer PHI-BLAST method, see:

Zhang, Zheng, Algandro A. Schéffer, Webb Miller, Thomas L. Madden, David J. Lipman,

Eugene V. Koonin and Stephen F. Altschul (1998), "Protein sequence similarity searches using
patterns as seeds’, Nucleic Acids Res. 26:3986-3990.
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BLAST Programs

BLAST offersthe following programs:

blastn: Search a nucleotide database with a nucleotide query

blastp: Search protein database with a protein query

tblastn: Search a six-frame dynamic translation of a nucleotide database with a protein query
blastx: Search a protein database with a six-frame transglation of a nucleotide query sequence.

tblastx: Search a six-frame trand ation o